summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-mac-update.bb
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2023-11-06 06:37:22 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2023-11-21 10:41:53 +0300
commitf7150ec37089cb4de33587ce004901314876b9df (patch)
tree98d27d2a18ead012d36e4332b39aa964a6e073cf /meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-mac-update.bb
parent437b4b9afa8b463958b2d741db212a5e30fc2cf6 (diff)
downloadopenbmc-f7150ec37089cb4de33587ce004901314876b9df.tar.xz
meta-ampere: mtmitchell: network: use sync-mac for MAC from FRU
Switch to use phosphor-networkd's sync-mac feature to get and use MAC address from FRU, replacing Ampere approach. Tested: 1. Boot the BMC to Linux and login to console 2. Get BMC MAC address in FRU $ ipmitool fru print 1 | grep "Board Extra" Board Extra : B4:05:5D:E1:01:BC 3. Check eth0 HWaddr with MAC in FRU $ ifconfig eth0 | grep HWaddr eth0 Link encap:Ethernet HWaddr B4:05:5D:E1:01:BC Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Signed-off-by: Khang Nguyen <khangng@amperecomputing.com> Change-Id: Ia31589bf75306ad5a3639cb46a73813957e85e9d
Diffstat (limited to 'meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-mac-update.bb')
-rw-r--r--meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-mac-update.bb18
1 files changed, 0 insertions, 18 deletions
diff --git a/meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-mac-update.bb b/meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-mac-update.bb
deleted file mode 100644
index 7deb05a219..0000000000
--- a/meta-ampere/meta-mitchell/recipes-ampere/platform/ampere-mac-update.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Ampere Computing LLC Update MAC Address from FRU Inventory Information"
-DESCRIPTION = "Update MAC Address from FRU Inventory Information for Ampere systems"
-PR = "r1"
-
-LICENSE = "Apache-2.0"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit systemd
-inherit obmc-phosphor-systemd
-
-DEPENDS = "systemd"
-RDEPENDS:${PN} = "bash"
-
-FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
-
-SYSTEMD_SERVICE:${PN} = "ampere_update_mac.service"
-