summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-mitchell/recipes-kernel
diff options
context:
space:
mode:
authorChanh Nguyen <chanh@os.amperecomputing.com>2022-04-28 12:11:28 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2022-10-15 02:04:30 +0300
commit2fc68eb6724541610fbae14c356b857fc529dd71 (patch)
tree3a1988c96eff73023d1aff3f7e713d53015bc06b /meta-ampere/meta-mitchell/recipes-kernel
parent9f71c1e71d618145d7bf82ee0d71ea06c3680a30 (diff)
downloadopenbmc-2fc68eb6724541610fbae14c356b857fc529dd71.tar.xz
meta-ampere: Initial AmpereOne(TM) Mt. Mitchell's non-DC-SCM BMC support
Add new Mt.Mitchell platform with basic features so that it can be compiled and works. Tested: 1. Compile for Mt.Mitchell successful. 2. Flash and check for the firmware can boot on the Mt.Mitchell non-DC-SCM system without issue Signed-off-by: Chanh Nguyen <chanh@os.amperecomputing.com> Change-Id: I8dc9db9029b27c0c6325c31d368cdbb614a3c8b6
Diffstat (limited to 'meta-ampere/meta-mitchell/recipes-kernel')
-rw-r--r--meta-ampere/meta-mitchell/recipes-kernel/linux/linux-aspeed/ampere.cfg36
-rw-r--r--meta-ampere/meta-mitchell/recipes-kernel/linux/linux-aspeed_%.bbappend5
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-ampere/meta-mitchell/recipes-kernel/linux/linux-aspeed/ampere.cfg b/meta-ampere/meta-mitchell/recipes-kernel/linux/linux-aspeed/ampere.cfg
new file mode 100644
index 0000000000..1990bf46ab
--- /dev/null
+++ b/meta-ampere/meta-mitchell/recipes-kernel/linux/linux-aspeed/ampere.cfg
@@ -0,0 +1,36 @@
+#
+# BOM
+#
+CONFIG_RTC_DRV_PCF85063=y
+CONFIG_IIO_MUX=y
+CONFIG_MUX_GPIO=y
+CONFIG_I2C_MUX=y
+
+CONFIG_SENSORS_IIO_HWMON=y
+CONFIG_ASPEED_ADC=y
+CONFIG_SENSORS_LM75=y
+CONFIG_SENSORS_EMC1403=y
+CONFIG_LTC2497=y
+CONFIG_I2C_SLAVE=y
+CONFIG_SENSORS_ASPEED=y
+
+CONFIG_USB_PHY=y
+CONFIG_USB_GADGET=y
+CONFIG_USB_CONFIGFS=y
+CONFIG_USB_ASPEED_VHUB=y
+CONFIG_USB_CONFIGFS_ECM=y
+
+CONFIG_HWMON=y
+
+CONFIG_PWM=y
+CONFIG_PWM_SYSFS=y
+CONFIG_SENSORS_PWM_FAN=y
+CONFIG_SENSORS_ASPEED=y
+
+CONFIG_REGULATOR_FIXED_VOLTAGE=y
+CONFIG_REGULATOR=y
+
+CONFIG_SENSORS_MAX31790=y
+
+CONFIG_NET_NCSI=y
+CONFIG_NCSI_OEM_CMD_GET_MAC=y
diff --git a/meta-ampere/meta-mitchell/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-ampere/meta-mitchell/recipes-kernel/linux/linux-aspeed_%.bbappend
new file mode 100644
index 0000000000..4cac8de388
--- /dev/null
+++ b/meta-ampere/meta-mitchell/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+ file://ampere.cfg \
+ "