summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-mitchell/recipes-phosphor/ipmi
diff options
context:
space:
mode:
authorHieu Huynh <hieuh@os.amperecomputing.com>2022-09-12 14:35:36 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2023-06-09 12:30:43 +0300
commitb953dc9a82c86358eb6343265f8e4ce3a5cd7739 (patch)
tree65d866378e2c3df25403c74e53587e11d48231fb /meta-ampere/meta-mitchell/recipes-phosphor/ipmi
parentfe4a607fe73cdeb166d2b021dbcea0ebf98b8917 (diff)
downloadopenbmc-b953dc9a82c86358eb6343265f8e4ce3a5cd7739.tar.xz
meta-ampere: mtmitchell: ipmi: support on-board sensor report
Support to report sensor information via IPMI for on-board sensors Tested: 1. Check sensor report using IPMI sdr command: $ ipmitool sdr list OutletTemp | 28 degrees C | ok Psu1InletTemp2 | 32 degrees C | ok PcieZoneTemp1 | 30 degrees C | ok Psu0InletTemp2 | 29 degrees C | ok PcieZoneTemp2 | 28 degrees C | ok Signed-off-by: Hieu Huynh <hieuh@os.amperecomputing.com> Change-Id: Ia38519c79596f65f780fe105ee25e8890825a44f
Diffstat (limited to 'meta-ampere/meta-mitchell/recipes-phosphor/ipmi')
-rw-r--r--meta-ampere/meta-mitchell/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-ampere/meta-mitchell/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-ampere/meta-mitchell/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
new file mode 100644
index 0000000000..7377e285e6
--- /dev/null
+++ b/meta-ampere/meta-mitchell/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+
+DEPENDS:append = " mtmitchell-yaml-config"
+
+EXTRA_OEMESON = " \
+ -Dsensor-yaml-gen=${STAGING_DIR_HOST}${datadir}/mtmitchell-yaml-config/ipmi-sensors.yaml \
+ -Dfru-yaml-gen=${STAGING_DIR_HOST}${datadir}/mtmitchell-yaml-config/ipmi-fru-read.yaml \
+ "