summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-mitchell/recipes-phosphor/skeleton
diff options
context:
space:
mode:
authorChanh Nguyen <chanh@os.amperecomputing.com>2022-04-28 12:11:28 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2022-10-15 02:04:30 +0300
commit2fc68eb6724541610fbae14c356b857fc529dd71 (patch)
tree3a1988c96eff73023d1aff3f7e713d53015bc06b /meta-ampere/meta-mitchell/recipes-phosphor/skeleton
parent9f71c1e71d618145d7bf82ee0d71ea06c3680a30 (diff)
downloadopenbmc-2fc68eb6724541610fbae14c356b857fc529dd71.tar.xz
meta-ampere: Initial AmpereOne(TM) Mt. Mitchell's non-DC-SCM BMC support
Add new Mt.Mitchell platform with basic features so that it can be compiled and works. Tested: 1. Compile for Mt.Mitchell successful. 2. Flash and check for the firmware can boot on the Mt.Mitchell non-DC-SCM system without issue Signed-off-by: Chanh Nguyen <chanh@os.amperecomputing.com> Change-Id: I8dc9db9029b27c0c6325c31d368cdbb614a3c8b6
Diffstat (limited to 'meta-ampere/meta-mitchell/recipes-phosphor/skeleton')
-rw-r--r--meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf/mtmitchell_gpio_defs.json45
-rw-r--r--meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend10
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf/mtmitchell_gpio_defs.json b/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf/mtmitchell_gpio_defs.json
new file mode 100644
index 0000000000..f3542849f0
--- /dev/null
+++ b/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf/mtmitchell_gpio_defs.json
@@ -0,0 +1,45 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "PGOOD",
+ "power_up_outs": [
+ {"name": "OCP_MAIN_PWREN", "polarity": true},
+ {"name": "BMC_SYS_PSON_L", "polarity": false}
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "PGOOD",
+ "pin": "H3",
+ "direction": "in"
+ },
+ {
+ "name": "BMC_SYS_PSON_L",
+ "pin": "F2",
+ "direction": "out"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "I6",
+ "direction": "both"
+ },
+ {
+ "name": "RESET_BUTTON",
+ "pin": "Z0",
+ "direction": "both"
+ },
+ {
+ "name": "OCP_MAIN_PWREN",
+ "pin": "W1",
+ "direction": "out"
+ },
+ {
+ "name": "ID_BTN",
+ "pin": "S2",
+ "direction": "both"
+ }
+ ]
+}
diff --git a/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
new file mode 100644
index 0000000000..331c244ab4
--- /dev/null
+++ b/meta-ampere/meta-mitchell/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+
+SRC_URI += "\
+ file://${MACHINE}_gpio_defs.json \
+ "
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/default/obmc/gpio/
+ install -m 0644 ${WORKDIR}/${MACHINE}_gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/gpio_defs.json
+}