summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-mitchell
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2023-12-11 10:45:07 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2023-12-15 09:54:52 +0300
commit0bb38d152cd28e699f21cf6d240f1f9ba886be5e (patch)
treee2d394335acf1acbdc3eb058e87e94169a334d68 /meta-ampere/meta-mitchell
parentf52f03231aa67aac86cd9d7134d39ff9ebfaceef (diff)
downloadopenbmc-0bb38d152cd28e699f21cf6d240f1f9ba886be5e.tar.xz
meta-ampere: configure presence interfaces
Add CPU and Power Supply presence interfaces using phosphor-multi-gpip-presence. Tested: 1. Check if CPU_x dbus exists $ busctl get-property xyz.openbmc_project.Inventory.Manager \ /xyz/openbmc_project/inventory/system/chassis/motherboard/CPU_2 \ xyz.openbmc_project.Inventory.Item PrettyName` s "CPU_2" 2. Check if sensors that are required with CPURequired are reported $ ipmitool sdr list Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I7ce9819f39f8a2afb386fa6b00421f1ead935189
Diffstat (limited to 'meta-ampere/meta-mitchell')
-rw-r--r--meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json26
-rw-r--r--meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend5
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json b/meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json
new file mode 100644
index 0000000000..e48a9888da
--- /dev/null
+++ b/meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json
@@ -0,0 +1,26 @@
+[
+ {
+ "Name": "CPU_1",
+ "LineName": "presence-cpu0",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/motherboard/CPU_1"
+ },
+ {
+ "Name": "CPU_2",
+ "LineName": "presence-cpu1",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/motherboard/CPU_2"
+ },
+ {
+ "Name": "PSU0",
+ "LineName": "presence-ps0",
+ "ActiveLow": true,
+ "Inventory": "/system/powersupply/PowerSupply0"
+ },
+ {
+ "Name": "CPU1",
+ "LineName": "presence-ps1",
+ "ActiveLow": true,
+ "Inventory": "/system/powersupply/PowerSupply1"
+ }
+]
diff --git a/meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index 32ce4b919a..50586a00cb 100644
--- a/meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-ampere/meta-mitchell/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -4,6 +4,7 @@ RDEPENDS:${PN}-monitor += "bash"
SRC_URI += " \
file://phosphor-multi-gpio-monitor.json \
+ file://phosphor-multi-gpio-presence.json \
"
SYSTEMD_SERVICE:${PN}-monitor += " \
@@ -14,8 +15,12 @@ SYSTEMD_SERVICE:${PN}-monitor += " \
FILES:${PN}-monitor += " \
${datadir}/${PN}/phosphor-multi-gpio-monitor.json \
"
+FILES:${PN}-presence += " \
+ ${datadir}/${PN}/phosphor-multi-gpio-presence.json \
+ "
do_install:append() {
install -d ${D}${bindir}
install -m 0644 ${WORKDIR}/phosphor-multi-gpio-monitor.json ${D}${datadir}/${PN}/
+ install -m 0644 ${WORKDIR}/phosphor-multi-gpio-presence.json ${D}${datadir}/${PN}/
}