summaryrefslogtreecommitdiff
path: root/meta-arm/.gitlab-ci.yml
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2023-07-21 17:06:10 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-08-04 00:02:23 +0300
commit23e02799f2c379a4725b7dad4a071253cf9794a8 (patch)
tree27af205828952a2d5acf58eff14939179ea640c5 /meta-arm/.gitlab-ci.yml
parent2c9842e3c4584e2d785a80c2d79732ed36273cf5 (diff)
downloadopenbmc-23e02799f2c379a4725b7dad4a071253cf9794a8.tar.xz
subtree updates july 21 2023 pi,security,arm
meta-arm: d6fac49541..b4d50a273d: Abdellatif El Khlifi (5): arm-bsp/documentation: corstone1000: Update change log arm-bsp/doc: corstone1000: Update the software architecture document arm-bsp/documentation: corstone1000: update the release note arm-bsp/documentation: corstone1000: update user guide kas: set the SHAs for 2023.06 release Jon Mason (7): arm/optee-test: modify to use build openssl arm/optee: update to 3.22.0 arm-bsp/machine: work around rootfs name issue ci/clang: add llvm-native from clang README arm/optee-os: update/clean-up patches and recipes arm-bsp/juno: remove commented out KCONFIG arm/linux-yocto: move 6.1 patches to a unique bbappend Khem Raj (1): gn: Disable warning as error but not disable completely Mikko Rapeli (1): optee-os optee-test: switch from SRC_URI:append to SRC_URI += Peter Hoyes (5): runfvp: Add missing conffile include arm/oeqa: Merge all OEFVP*Target classes arm/OEFVPTarget: Add support for model state transitions arm/oeqa: Convert linuxboot test case into fvp_boot arm/oeqa: Introduce the fvp_devices test suite Ross Burton (14): CI: use Kas 3.3 CI: update to Kas format 14 CI: use branch, not refspec CI: generate and use a Kas lock file CI: add a tool to fetch a lockfile.yml for a specified build arm/scp-firmware: set default SCP_PLATFORM to MACHINE arm-bsp/scp-firmware: remove redundant SCP_PLATFORM arm/scp-firware: update compiler variables arm/scp-firmware: log what platform/firmware/type is being built arm/scp-firmware: fix intermittent compile failures CI: track master arm-bsp/u-boot: add temporary 2023.01 recipe toolchain: remove pointless provides arm-bsp/linux-yocto: fix Upstream-Status Rouven Czerwinski (3): optee-os: add optional optee-os-ta package optee-os: deploy ta elf files optee-test: add TA elfs to deploydir Tomás González (2): arm-bsp/documentation: corstone1000: Update the user guide arm-bsp/documentation: corstone1000: Update the release notes Ziad Elhanafy (5): arm-bsp/conf: Remove hardcoded .rootfs from image path arm/classes: Remove IMAGE_NAME_SUFFIX from image path arm: Set FVP EULA environment variable details message kas: Add fvp-eula.yml and remove license related settings arm-bsp/documentation: Replace FVP_BASE_R_ARM_EULA_ACCEPT with ARM_FVP_EULA_ACCEPT meta-raspberrypi: dff85b9a9f..e3f733cadd: Khem Raj (1): linux-raspberrypi_6.1.bb: Update to 6.1.38 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: Iebdd94d49998e9297e49ee2463761f2f3acb45c1
Diffstat (limited to 'meta-arm/.gitlab-ci.yml')
-rw-r--r--meta-arm/.gitlab-ci.yml26
1 files changed, 19 insertions, 7 deletions
diff --git a/meta-arm/.gitlab-ci.yml b/meta-arm/.gitlab-ci.yml
index b2246743f7..4a786f633b 100644
--- a/meta-arm/.gitlab-ci.yml
+++ b/meta-arm/.gitlab-ci.yml
@@ -1,4 +1,4 @@
-image: ghcr.io/siemens/kas/kas:3.2.3
+image: ghcr.io/siemens/kas/kas:3.3
variables:
CPU_REQUEST: ""
@@ -58,8 +58,8 @@ stages:
# Catch all for everything else
- if: '$KERNEL != "linux-yocto-dev"'
script:
- - KASFILES=$(./ci/jobs-to-kas "$CI_JOB_NAME")
- - kas dump --update --force-checkout --resolve-refs --resolve-env $KASFILES
+ - KASFILES=$(./ci/jobs-to-kas "$CI_JOB_NAME"):lockfile.yml
+ - kas dump --update --force-checkout --resolve-refs --resolve-env $KASFILES
- kas build $KASFILES
- ./ci/check-warnings $KAS_WORK_DIR/build/warnings.log
artifacts:
@@ -77,7 +77,19 @@ update-repos:
extends: .setup
stage: prep
script:
- - flock --verbose --timeout 60 $KAS_REPO_REF_DIR ./ci/update-repos
+ - |
+ flock --verbose --timeout 60 $KAS_REPO_REF_DIR ./ci/update-repos
+ # Only generate if doesn't already exist, to allow feature branches to drop one in.
+ if test -f lockfile.yml; then
+ echo Using existing lockfile.yml
+ else
+ # Be sure that this is the complete list of layers being fetched
+ kas dump --lock --update ci/qemuarm64.yml:ci/meta-openembedded.yml:ci/clang.yml:ci/meta-virtualization.yml | tee lockfile.yml
+ fi
+ artifacts:
+ name: "lockfile"
+ paths:
+ - lockfile.yml
#
# Build stage, the actual build jobs
@@ -233,14 +245,14 @@ toolchains:
selftest:
extends: .setup
script:
- - KASFILES=./ci/qemuarm64.yml:./ci/selftest.yml
+ - KASFILES=./ci/qemuarm64.yml:./ci/selftest.yml:lockfile.yml
- kas shell --update --force-checkout $KASFILES -c 'oe-selftest --num-processes 1 --run-tests runfvp'
# Validate layers are Yocto Project Compatible
check-layers:
extends: .setup
script:
- - kas shell --update --force-checkout ci/base.yml:ci/meta-openembedded.yml --command \
+ - kas shell --update --force-checkout ci/base.yml:ci/meta-openembedded.yml:lockfile.yml --command \
"yocto-check-layer-wrapper $CI_PROJECT_DIR/$LAYER --dependency $CI_PROJECT_DIR/meta-* $KAS_WORK_DIR/meta-openembedded/meta-oe --no-auto-dependency"
parallel:
matrix:
@@ -254,7 +266,7 @@ pending-updates:
script:
- rm -fr update-report
# This configuration has all of the layers we need enabled
- - kas shell --update --force-checkout ci/qemuarm64.yml:ci/meta-openembedded.yml --command \
+ - kas shell --update --force-checkout ci/qemuarm64.yml:ci/meta-openembedded.yml:lockfile.yml --command \
"$CI_PROJECT_DIR/scripts/machine-summary.py -t report -o $CI_PROJECT_DIR/update-report $($CI_PROJECT_DIR/ci/listmachines.py meta-arm meta-arm-bsp)"
# Do this on x86 whilst the compilers are x86-only
tags: