summaryrefslogtreecommitdiff
path: root/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
diff options
context:
space:
mode:
authorAndrei Kartashev <a.kartashev@yadro.com>2021-10-08 00:14:45 +0300
committerJoel Stanley <joel@jms.id.au>2021-10-11 07:47:39 +0300
commitc5b413fe47be3bf5f8e71f9ce6e1f455e872c339 (patch)
tree614069c7b979aeed2869836cbc794d565a708be2 /meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
parentaeca9fc82682e5b86b19f5c236e4fd37d2bda220 (diff)
downloadopenbmc-c5b413fe47be3bf5f8e71f9ce6e1f455e872c339.tar.xz
u-boot-aspeed: use upstream u-boot.inc
Move u-boot-aspeed-sdk to use u-boot.inc from poki instead our own. We still need our own one for old u-boot-aspeed, so keep it as is. Tested: Build image for AST2500-based machine with u-boot-aspeed-sdk_2019.04, verified that it boots up and fw-utils installed to the image properly. Signed-off-by: Andrei Kartashev <a.kartashev@yadro.com> Change-Id: Ia5fecdedc94e9550196420884a727e7d87b313d4
Diffstat (limited to 'meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 6c1470a5f8..90e1206771 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -19,23 +19,23 @@ EXTRA_OEMAKE:class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config
do_compile () {
- oe_runmake ${UBOOT_MACHINE}
+ oe_runmake -C ${S} O=${B} ${UBOOT_MACHINE}
oe_runmake envtools
}
do_install () {
install -d ${D}${base_sbindir}
- install -d ${D}${sysconfdir}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -m 755 ${B}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ ln -sf fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -d ${D}${sysconfdir}
install -m 644 ${WORKDIR}/${ENV_CONFIG_FILE} ${D}${sysconfdir}/fw_env.config
}
do_install:class-cross () {
install -d ${D}${bindir_cross}
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
- install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+ install -m 755 ${B}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ ln -sf fw_printenv ${D}${bindir_cross}/fw_setenv
}
SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"