summaryrefslogtreecommitdiff
path: root/meta-aspeed/recipes-bsp
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2022-05-02 03:21:40 +0300
committerJoel Stanley <joel@jms.id.au>2022-05-02 23:07:19 +0300
commitb0683cc89e4bf417a702ff9d735542c00490716b (patch)
tree66fa3f394a3da00a695e88f2e935ec21bfbad5bc /meta-aspeed/recipes-bsp
parent568f2e3c8bbd2d655bdf7562fda105d24c6e8b58 (diff)
downloadopenbmc-b0683cc89e4bf417a702ff9d735542c00490716b.tar.xz
meta-aspeed: Consolidate u-boot fw_env configuration
The 32MB and 64MB NOR environments are the same configuration, so use the one file. The AST2600 NOR layout is the same size as the others so it can use the same file too. Change-Id: I6ee3fbf0d68104bcc684c2536fe85c5aec76c409 Signed-off-by: Joel Stanley <joel@jms.id.au>
Diffstat (limited to 'meta-aspeed/recipes-bsp')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_nor.config2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_64M_nor.config2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_nor.config (renamed from meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_32M_nor.config)0
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb10
4 files changed, 3 insertions, 11 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_nor.config b/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_nor.config
deleted file mode 100644
index ccd037ee62..0000000000
--- a/meta-aspeed/recipes-bsp/u-boot/files/fw_env_ast2600_nor.config
+++ /dev/null
@@ -1,2 +0,0 @@
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-/dev/mtd/u-boot-env 0x0000 0x10000 0x1000
diff --git a/meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_64M_nor.config b/meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_64M_nor.config
deleted file mode 100644
index 52d0882661..0000000000
--- a/meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_64M_nor.config
+++ /dev/null
@@ -1,2 +0,0 @@
-# MTD device name Device offset Env. size Flash sector size Number of sectors
-/dev/mtd/u-boot-env 0x0000 0x20000 0x1000
diff --git a/meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_32M_nor.config b/meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_nor.config
index 52d0882661..52d0882661 100644
--- a/meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_32M_nor.config
+++ b/meta-aspeed/recipes-bsp/u-boot/files/fw_env_flash_nor.config
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 1a7e8f5b7c..e02369fd4b 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -8,16 +8,12 @@ DEPENDS += "mtd-utils"
PROVIDES += "u-boot-fw-utils"
RPROVIDES:${PN} += "u-boot-fw-utils"
-SRC_URI += "file://fw_env_ast2600_nor.config"
+# The 32MB NOR and 64MB NOR layouts use the same configuration
+SRC_URI += "file://fw_env_flash_nor.config"
SRC_URI += "file://fw_env_ast2600_mmc.config"
-SRC_URI += "file://fw_env_flash_32M_nor.config"
-SRC_URI += "file://fw_env_flash_64M_nor.config"
-SRC_URI:append:uboot-flash-32768 = " file://u-boot_flash_32M.cfg"
-ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
+ENV_CONFIG_FILE = "fw_env_flash_nor.config"
ENV_CONFIG_FILE:df-phosphor-mmc = "fw_env_ast2600_mmc.config"
-ENV_CONFIG_FILE:uboot-flash-32768 = "fw_env_flash_32M_nor.config"
-ENV_CONFIG_FILE:uboot-flash-65536 = "fw_env_flash_64M_nor.config"
INSANE_SKIP:${PN} = "already-stripped"
EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'