summaryrefslogtreecommitdiff
path: root/meta-asrock/meta-romed8hm3/recipes-x86
diff options
context:
space:
mode:
authorZev Weiss <zev@bewilderbeest.net>2022-04-02 03:06:34 +0300
committerZev Weiss <zev@bewilderbeest.net>2023-01-19 10:01:44 +0300
commitb46c6f08dec0452cfc8e9146da76205020b13658 (patch)
treeac3ca73809a7f3629d295cde20e841fe199b77c0 /meta-asrock/meta-romed8hm3/recipes-x86
parent4315726460fa167740c3d1ee09a64700dd6db99f (diff)
downloadopenbmc-b46c6f08dec0452cfc8e9146da76205020b13658.tar.xz
romed8hm3: Enable x86-power-control, add config
Signed-off-by: Zev Weiss <zev@bewilderbeest.net> Change-Id: Ifa6ea971eec3ceef9c2ba4d8ec8b1ef922d21d61
Diffstat (limited to 'meta-asrock/meta-romed8hm3/recipes-x86')
-rw-r--r--meta-asrock/meta-romed8hm3/recipes-x86/chassis/x86-power-control/power-config-host0.json87
-rw-r--r--meta-asrock/meta-romed8hm3/recipes-x86/chassis/x86-power-control_%.bbappend10
2 files changed, 97 insertions, 0 deletions
diff --git a/meta-asrock/meta-romed8hm3/recipes-x86/chassis/x86-power-control/power-config-host0.json b/meta-asrock/meta-romed8hm3/recipes-x86/chassis/x86-power-control/power-config-host0.json
new file mode 100644
index 0000000000..7b116bdfb6
--- /dev/null
+++ b/meta-asrock/meta-romed8hm3/recipes-x86/chassis/x86-power-control/power-config-host0.json
@@ -0,0 +1,87 @@
+{
+ "gpio_configs": [
+ {
+ "Name" : "IdButton",
+ "LineName" : "LOCATORBTN",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ },
+ {
+ "Name" : "NMIButton",
+ "LineName" : "NMI_BTN_N",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ },
+ {
+ "Name" : "NMIOut",
+ "LineName" : "BMC_NMI",
+ "Type" : "GPIO",
+ "Polarity": "ActiveHigh"
+ },
+ {
+ "Name" : "PostComplete",
+ "LineName" : "POST_COMPLETE_N",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ },
+ {
+ "Name" : "PowerButton",
+ "LineName" : "BMC_PSIN",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ },
+ {
+ "Name" : "PowerOk",
+ "LineName" : "PWRGD_OUT",
+ "Type" : "GPIO",
+ "Polarity": "ActiveHigh"
+ },
+ {
+ "Name" : "PowerOut",
+ "LineName" : "BMC_PSOUT",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ },
+ {
+ "Name" : "ResetButton",
+ "LineName" : "BMC_RESETCON",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ },
+ {
+ "Name" : "ResetOut",
+ "LineName" : "RESETCON",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ },
+ {
+ "Name" : "SioOnControl",
+ "LineName" : "",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ },
+ {
+ "Name" : "SioPowerGood",
+ "LineName" : "",
+ "Type" : "GPIO",
+ "Polarity": "ActiveHigh"
+ },
+ {
+ "Name" : "SIOS5",
+ "LineName" : "",
+ "Type" : "GPIO",
+ "Polarity": "ActiveLow"
+ }
+ ],
+ "timing_configs": {
+ "PowerPulseMs": 200,
+ "ForceOffPulseMs": 15000,
+ "ResetPulseMs": 500,
+ "PowerCycleMs": 5000,
+ "SioPowerGoodWatchdogMs": 1000,
+ "PsPowerOKWatchdogMs": 8000,
+ "GracefulPowerOffS": 300,
+ "WarmResetCheckMs": 500,
+ "PowerOffSaveMs": 7000
+ }
+}
diff --git a/meta-asrock/meta-romed8hm3/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-asrock/meta-romed8hm3/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100644
index 0000000000..aed15e25fb
--- /dev/null
+++ b/meta-asrock/meta-romed8hm3/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+ file://power-config-host0.json \
+ "
+
+do_install:append() {
+ install -d ${D}/${datadir}/${PN}
+ install -m 0644 ${WORKDIR}/power-config-host0.json ${D}/${datadir}/${PN}
+}