summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-bletchley/recipes-bletchley
diff options
context:
space:
mode:
authorPotin Lai <potin.lai@quantatw.com>2023-03-06 09:33:00 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-03-10 02:00:04 +0300
commit31cca7c34ed29aa51eb480500d7bd3464efa6d22 (patch)
treeddb86399fe0b3ed103d30aa4cda1447089bc9fff /meta-facebook/meta-bletchley/recipes-bletchley
parent93e6bbee156d2ba3232cc54ea9623119c4b0e749 (diff)
downloadopenbmc-31cca7c34ed29aa51eb480500d7bd3464efa6d22.tar.xz
meta-bletchley: move chassis and host power control service into phosphor-state-manager
Move chassis and host power control services as part of PSM package to align with other platforms in meta-facebook. Signed-off-by: Potin Lai <potin.lai@quantatw.com> Change-Id: I6e6afc0ad62d3b872b330202a4696b704d245911
Diffstat (limited to 'meta-facebook/meta-bletchley/recipes-bletchley')
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-insertion@.target4
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-removal@.target2
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-ac-off@.service9
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-ac-on@.service14
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-cycle@.service9
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-poweroff@.service11
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-poweron@.service13
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-reset@.service9
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb26
9 files changed, 3 insertions, 94 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-insertion@.target b/meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-insertion@.target
index 6fef027ee3..6b516a18ea 100644
--- a/meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-insertion@.target
+++ b/meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-insertion@.target
@@ -1,8 +1,8 @@
[Unit]
Description=Bletchlet SLED%i insertion target
-Requires=host-ac-on@%i.service
-After=host-ac-on@%i.service
+Requires=chassis-poweron@%i.service
+After=chassis-poweron@%i.service
Requires=motor-init-calibration@%i.service
After=motor-init-calibration@%i.service
Conflicts=bletchley-sled-removed@%i.target
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-removal@.target b/meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-removal@.target
index 55fd5c3646..4fd59186f2 100644
--- a/meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-removal@.target
+++ b/meta-facebook/meta-bletchley/recipes-bletchley/detect-gpio-present/files/bletchley-sled-removal@.target
@@ -2,7 +2,7 @@
Description=Bletchlet SLED%i removal target
Conflicts=motor-init-calibration@%i.service
-Conflicts=host-ac-on@%i.service
+Conflicts=chassis-poweron@%i.service
Conflicts=bletchley-sled-insertion@%i.target
RefuseManualStop=yes \ No newline at end of file
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-ac-off@.service b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-ac-off@.service
deleted file mode 100644
index 6b42f8f067..0000000000
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-ac-off@.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=Turn off AC at Sled%i
-Conflicts=host-ac-on@%i.service
-After=host-poweroff@%i.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/sbin/power-ctrl sled%i ac-off
-SyslogIdentifier=power-ctrl
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-ac-on@.service b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-ac-on@.service
deleted file mode 100644
index 657b2a8ea9..0000000000
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-ac-on@.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Turn on AC at Sled%i
-Requires=motor-init-calibration@%i.service
-After=motor-init-calibration@%i.service
-Conflicts=host-ac-off@%i.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/sbin/power-ctrl sled%i ac-on
-SyslogIdentifier=power-ctrl
-ExecStartPost=/bin/systemctl restart phosphor-discover-system-state@%i.service
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-cycle@.service b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-cycle@.service
deleted file mode 100644
index 2fb7d9dbba..0000000000
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-cycle@.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=Sled%i Host Power Cycle
-Requires=motor-init-calibration@%i.service
-After=motor-init-calibration@%i.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/sbin/power-ctrl sled%i cycle
-SyslogIdentifier=power-ctrl
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-poweroff@.service b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-poweroff@.service
deleted file mode 100644
index c81f6d6a19..0000000000
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-poweroff@.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Power off System in Sled%i by Step Motor
-Requires=motor-init-calibration@%i.service
-After=motor-init-calibration@%i.service
-Conflicts=host-poweron@%i.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/sbin/power-ctrl sled%i off
-SyslogIdentifier=power-ctrl
-
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-poweron@.service b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-poweron@.service
deleted file mode 100644
index fd0cbd93af..0000000000
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-poweron@.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Power on System in Sled%i by Step Motor
-Requires=motor-init-calibration@%i.service
-After=motor-init-calibration@%i.service
-Requires=host-ac-on@%i.service
-After=host-ac-on@%i.service
-Conflicts=host-poweroff@%i.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/sbin/power-ctrl sled%i boot-from-bootmode
-SyslogIdentifier=power-ctrl
-
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-reset@.service b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-reset@.service
deleted file mode 100644
index a8b6a082a1..0000000000
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/files/host-reset@.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=Sled%i Host Power Reset
-Requires=motor-init-calibration@%i.service
-After=motor-init-calibration@%i.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/sbin/power-ctrl sled%i reset
-SyslogIdentifier=power-ctrl
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
index 329c6f8717..a0e85bd0cc 100644
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
+++ b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
@@ -29,31 +29,5 @@ do_install() {
TGT = "${SYSTEMD_DEFAULT_TARGET}"
MOTOR_INIT_INSTFMT="../motor-init-calibration@.service:${TGT}.wants/motor-init-calibration@{0}.service"
-PWR_ON_INSTFMT="../host-poweron@.service:obmc-host-starting@{0}.target.wants/host-poweron@{0}.service"
-PWR_OFF_INSTFMT="../host-poweroff@.service:obmc-host-stopping@{0}.target.wants/host-poweroff@{0}.service"
-PWR_RESET_INSTFMT="host-reset@.service:host-reset@{0}.service"
-PWR_CYCLE_INSTFMT="host-cycle@.service:host-cycle@{0}.service"
-AC_ON_INSTFMT="../host-ac-on@.service:obmc-chassis-poweron@{0}.target.requires/host-ac-on@{0}.service"
-AC_OFF_INSTFMT="../host-ac-off@.service:obmc-chassis-poweroff@{0}.target.requires/host-ac-off@{0}.service"
-
SYSTEMD_SERVICE:${PN} += "motor-init-calibration@.service"
SYSTEMD_LINK:${PN} += "${@compose_list(d, 'MOTOR_INIT_INSTFMT', 'OBMC_HOST_INSTANCES')}"
-
-SYSTEMD_SERVICE:${PN} += "host-poweron@.service"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'PWR_ON_INSTFMT', 'OBMC_HOST_INSTANCES')}"
-
-SYSTEMD_SERVICE:${PN} += "host-poweroff@.service"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'PWR_OFF_INSTFMT', 'OBMC_HOST_INSTANCES')}"
-
-SYSTEMD_SERVICE:${PN} += "host-reset@.service"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'PWR_RESET_INSTFMT', 'OBMC_HOST_INSTANCES')}"
-
-SYSTEMD_SERVICE:${PN} += "host-cycle@.service"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'PWR_CYCLE_INSTFMT', 'OBMC_HOST_INSTANCES')}"
-
-SYSTEMD_SERVICE:${PN} += "host-ac-on@.service"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'AC_ON_INSTFMT', 'OBMC_HOST_INSTANCES')}"
-
-SYSTEMD_SERVICE:${PN} += "host-ac-off@.service"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'AC_OFF_INSTFMT', 'OBMC_HOST_INSTANCES')}"
-