summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-bletchley/recipes-bletchley
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2022-11-14 23:45:17 +0300
committerAndrew Geissler <andrew@geissonator.com>2022-11-28 21:20:11 +0300
commit5d4ef5198eff32594dd47998cb6ba066b3e5d6fd (patch)
tree111c7e474d346929e1e6b27dc7373b7af2721a89 /meta-facebook/meta-bletchley/recipes-bletchley
parentf37a30a2e8bbc023cdb333243c34d16e9d7ec51b (diff)
downloadopenbmc-5d4ef5198eff32594dd47998cb6ba066b3e5d6fd.tar.xz
state-management: move target relationship creation
The targets are within the phosphor-state-manager repository so the relationship between them should be defined within the corresponding recipe. Adding these to phosphor-state-manager also allows us to remove the duplicate logic in the bletchley layer. Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I8bc789ed25a937ed38840e398dd728782f8f368b
Diffstat (limited to 'meta-facebook/meta-bletchley/recipes-bletchley')
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb21
1 files changed, 0 insertions, 21 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
index 73932a183e..cb4554a225 100644
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
+++ b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
@@ -57,27 +57,6 @@ SYSTEMD_LINK:${PN} += "${@compose_list(d, 'AC_ON_INSTFMT', 'OBMC_HOST_INSTANCES'
SYSTEMD_SERVICE:${PN} += "host-ac-off@.service"
SYSTEMD_LINK:${PN} += "${@compose_list(d, 'AC_OFF_INSTFMT', 'OBMC_HOST_INSTANCES')}"
-# Host on requires these chassis on
-START_TMPL_CTRL = "obmc-chassis-poweron@.target"
-START_TGTFMT_CTRL = "obmc-host-startmin@{0}.target"
-START_INSTFMT_CTRL = "obmc-chassis-poweron@{0}.target"
-START_FMT_CTRL = "../${START_TMPL_CTRL}:${START_TGTFMT_CTRL}.requires/${START_INSTFMT_CTRL}"
-SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT_CTRL', 'OBMC_HOST_INSTANCES')}"
-
-# Chassis off requires host off
-STOP_TMPL_CTRL = "obmc-host-stop@.target"
-STOP_TGTFMT_CTRL = "obmc-chassis-poweroff@{0}.target"
-STOP_INSTFMT_CTRL = "obmc-host-stop@{0}.target"
-STOP_FMT_CTRL = "../${STOP_TMPL_CTRL}:${STOP_TGTFMT_CTRL}.requires/${STOP_INSTFMT_CTRL}"
-SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'STOP_FMT_CTRL', 'OBMC_HOST_INSTANCES')}"
-
-# Hard power off requires chassis off
-HARD_OFF_TMPL_CTRL = "obmc-chassis-poweroff@.target"
-HARD_OFF_TGTFMT_CTRL = "obmc-chassis-hard-poweroff@{0}.target"
-HARD_OFF_INSTFMT_CTRL = "obmc-chassis-poweroff@{0}.target"
-HARD_OFF_FMT_CTRL = "../${HARD_OFF_TMPL_CTRL}:${HARD_OFF_TGTFMT_CTRL}.requires/${HARD_OFF_INSTFMT_CTRL}"
-SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HARD_OFF_FMT_CTRL', 'OBMC_HOST_INSTANCES')}"
-
# Host on unit configurations
HOST_ON_OVERRIDE_CONF_FMT = "host-poweron.conf:host-poweron@{0}.service.d/host-poweron.conf"
SYSTEMD_OVERRIDE:${PN}:bletchley += "${@compose_list_zip(d, 'HOST_ON_OVERRIDE_CONF_FMT', 'OBMC_HOST_INSTANCES')}"