summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-bletchley
diff options
context:
space:
mode:
authorDelphine CC Chiu <Delphine_CC_Chiu@wiwynn.com>2023-06-27 08:48:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-08-07 00:14:13 +0300
commit796196a605a2179023b397a276f90c735a371e0d (patch)
tree1d560d96d259d026068359e2b476dc320b5b41b3 /meta-facebook/meta-bletchley
parent454ea369f06541c95a41fef9f5f4bb53bf665434 (diff)
downloadopenbmc-796196a605a2179023b397a276f90c735a371e0d.tar.xz
meta-facebook: move nvme_config.json into project layer
Description: Very few machines use phosphor-nvme and the current common meta-facebook bbappend forces every machine to create a bogus empty JSON file in order to prevent bitbake missing SRC_URI errors. Move these configs out of the common layer and into the machine-specific layer. Change-Id: Ie8558db2ed394a414e9dce70f73d2eb8693448f9 Signed-off-by: Delphine CC Chiu <Delphine_CC_Chiu@wiwynn.com> Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-facebook/meta-bletchley')
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme/nvme_config.json39
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend4
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme/nvme_config.json b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme/nvme_config.json
new file mode 100644
index 0000000000..32e36a5225
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme/nvme_config.json
@@ -0,0 +1,39 @@
+{
+ "maxSmbusErrorRetry": 3,
+ "config": [
+ {
+ "NVMeDriveIndex": 1,
+ "NVMeDriveBusID": 0
+ },
+ {
+ "NVMeDriveIndex": 2,
+ "NVMeDriveBusID": 1
+ },
+ {
+ "NVMeDriveIndex": 3,
+ "NVMeDriveBusID": 2
+ },
+ {
+ "NVMeDriveIndex": 4,
+ "NVMeDriveBusID": 3
+ },
+ {
+ "NVMeDriveIndex": 5,
+ "NVMeDriveBusID": 4
+ },
+ {
+ "NVMeDriveIndex": 6,
+ "NVMeDriveBusID": 5
+ }
+ ],
+ "threshold": [
+ {
+ "criticalHigh": 68,
+ "criticalLow": 0,
+ "warningHigh": 67,
+ "warningLow": 1,
+ "maxValue": 127,
+ "minValue": -127
+ }
+ ]
+}
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
index d495c8d831..84df1a16c1 100644
--- a/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
@@ -5,6 +5,7 @@ inherit obmc-phosphor-systemd
SRC_URI:append:bletchley = " \
file://nvme-json-rewrite \
file://nvme-json-rewrite.conf \
+ file://nvme_config.json \
"
RDEPENDS:${PN}:bletchley += "bash"
@@ -12,6 +13,9 @@ RDEPENDS:${PN}:bletchley += "bash"
do_install:append:bletchley() {
install -d ${D}${libexecdir}/${PN}/
install -m 0755 ${WORKDIR}/nvme-json-rewrite ${D}${libexecdir}/${PN}/
+
+ install -d ${D}${sysconfdir}/nvme
+ install -m 0644 -D ${WORKDIR}/nvme_config.json ${D}${sysconfdir}/nvme
}
SYSTEMD_OVERRIDE:${PN}:append:bletchley = " \