summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-bletchley
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2024-01-20 01:45:58 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-01-20 01:46:02 +0300
commitd3135247287cb3a4b932a89c088c9011b4a19a56 (patch)
treea5ba56efb8937c02e7bdeed354c42015e0a147ee /meta-facebook/meta-bletchley
parentcf77973df7b3fdce9ec381c4599ef2a12873e6ce (diff)
downloadopenbmc-d3135247287cb3a4b932a89c088c9011b4a19a56.tar.xz
meta-facebook: reduce permissions on scripts
Scripts should be installed with 0755 permissions and not 0777, otherwise non-root users can potentially modify or delete them. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I41270a2bb3fb940d8ca49ed6230545d98efb2fea
Diffstat (limited to 'meta-facebook/meta-bletchley')
-rw-r--r--meta-facebook/meta-bletchley/recipes-phosphor/state/phosphor-state-manager_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-facebook/meta-bletchley/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 6b6062c30a..1cc021a6b2 100644
--- a/meta-facebook/meta-bletchley/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -17,7 +17,7 @@ do_install:append:bletchley() {
install -m 0644 ${WORKDIR}/*.service ${D}${systemd_system_unitdir}/
install -d ${D}${libexecdir}/${PN}
- install -m 0777 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/${PN}/
}
FILES:${PN}:append:bletchley = " ${systemd_system_unitdir}"