summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-yosemite4/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
diff options
context:
space:
mode:
authorChris Wang <Chris_Wang@wiwynn.com>2024-03-12 12:29:15 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-03-13 05:13:44 +0300
commit0598b574e8a02209ba089c9bfadd6c5a9cc0b3b0 (patch)
tree65880a5b76e995aa0e5e97712d6e982a79075127 /meta-facebook/meta-yosemite4/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
parent9c40b39ecccb09f54c5d31ece58bfbc017bbc5d8 (diff)
downloadopenbmc-0598b574e8a02209ba089c9bfadd6c5a9cc0b3b0.tar.xz
meta-facebook: yosemite4: Support NIC endpoint setup
Setup the MCTP Endpoint for the NIC when inserted. Remove the MCTP Endpoint for the NIC when unplugged. Change-Id: I0c36cecda6509a64e4f26c70bf61590467571a7b Signed-off-by: Delphine CC Chiu <Delphine_CC_Chiu@wiwynn.com>
Diffstat (limited to 'meta-facebook/meta-yosemite4/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend')
-rw-r--r--meta-facebook/meta-yosemite4/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-facebook/meta-yosemite4/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-facebook/meta-yosemite4/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index 135d8e7f75..9033632150 100644
--- a/meta-facebook/meta-yosemite4/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-facebook/meta-yosemite4/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -3,6 +3,9 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
inherit obmc-phosphor-systemd systemd
SRC_URI += "file://yosemite4-phosphor-multi-gpio-monitor.json \
+ file://configure-nic-mctp-endpoint.sh \
+ file://setup-nic-endpoint-slot@.service \
+ file://remove-nic-endpoint-slot@.service \
file://set-button-sled.service \
file://probe-slot-device@.service \
file://probe-slot-device \
@@ -20,6 +23,8 @@ SYSTEMD_SERVICE:${PN} += " \
probe-slot-device@.service \
rescan-fru-device@.service \
slot-hot-plug@.service \
+ setup-nic-endpoint-slot@.service \
+ remove-nic-endpoint-slot@.service \
"
SYSTEMD_AUTO_ENABLE = "enable"
@@ -32,7 +37,11 @@ do_install:append:() {
install -m 0644 ${WORKDIR}/probe-slot-device@.service ${D}${systemd_system_unitdir}/probe-slot-device@.service
install -m 0644 ${WORKDIR}/rescan-fru-device@.service ${D}${systemd_system_unitdir}/rescan-fru-device@.service
install -m 0644 ${WORKDIR}/slot-hot-plug@.service ${D}${systemd_system_unitdir}/slot-hot-plug@.service
+ install -m 0644 ${WORKDIR}/setup-nic-endpoint-slot@.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${WORKDIR}/remove-nic-endpoint-slot@.service ${D}${systemd_system_unitdir}/
install -d ${D}${libexecdir}/${PN}
install -m 0755 ${WORKDIR}/probe-slot-device ${D}${libexecdir}/${PN}/
install -m 0755 ${WORKDIR}/rescan-fru-device ${D}${libexecdir}/${PN}/
+ install -d ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/configure-nic-mctp-endpoint.sh ${D}/${bindir}/
}