summaryrefslogtreecommitdiff
path: root/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2024-01-20 01:45:58 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-01-20 01:46:02 +0300
commitd3135247287cb3a4b932a89c088c9011b4a19a56 (patch)
treea5ba56efb8937c02e7bdeed354c42015e0a147ee /meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
parentcf77973df7b3fdce9ec381c4599ef2a12873e6ce (diff)
downloadopenbmc-d3135247287cb3a4b932a89c088c9011b4a19a56.tar.xz
meta-facebook: reduce permissions on scripts
Scripts should be installed with 0755 permissions and not 0777, otherwise non-root users can potentially modify or delete them. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I41270a2bb3fb940d8ca49ed6230545d98efb2fea
Diffstat (limited to 'meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend')
-rw-r--r--meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index dc7fdecfcc..8d48c68917 100644
--- a/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -49,15 +49,15 @@ do_install:append:greatlakes() {
install -m 0644 ${WORKDIR}/*.service ${D}${systemd_system_unitdir}/
install -d ${D}${libexecdir}/${PN}
- install -m 0777 ${WORKDIR}/chassis-poweroff ${D}${libexecdir}/${PN}/
- install -m 0777 ${WORKDIR}/chassis-poweron ${D}${libexecdir}/${PN}/
- install -m 0777 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/${PN}/
- install -m 0777 ${WORKDIR}/host-poweroff ${D}${libexecdir}/${PN}/
- install -m 0777 ${WORKDIR}/host-poweron ${D}${libexecdir}/${PN}/
- install -m 0777 ${WORKDIR}/host-powercycle ${D}${libexecdir}/${PN}/
- install -m 0777 ${WORKDIR}/host-powerreset ${D}${libexecdir}/${PN}/
- install -m 0777 ${WORKDIR}/power-cmd ${D}${libexecdir}/${PN}/
- install -m 0777 ${WORKDIR}/power-ctrl-init ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/chassis-poweroff ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/chassis-poweron ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/host-poweroff ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/host-poweron ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/host-powercycle ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/host-powerreset ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/power-cmd ${D}${libexecdir}/${PN}/
+ install -m 0755 ${WORKDIR}/power-ctrl-init ${D}${libexecdir}/${PN}/
}
FILES:${PN} += " ${systemd_system_unitdir}/*.service"