summaryrefslogtreecommitdiff
path: root/meta-facebook/recipes-phosphor/state
diff options
context:
space:
mode:
authorKarthikeyan Pasupathi <pkarthikeyan1509@gmail.com>2023-01-20 17:24:43 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-01-25 07:05:38 +0300
commit60e2e535983e281cb14fadd82edee94291f4287f (patch)
treed5d006787fba07722b79b84c1c941edc1af20ca6 /meta-facebook/recipes-phosphor/state
parente713a6fa3e4b21150a325c7c33007da0a6079188 (diff)
downloadopenbmc-60e2e535983e281cb14fadd82edee94291f4287f.tar.xz
meta-facebook: greatlakes: fix overriding issue in DEFAULT_TARGETS variable
The existing implementation completely override the DEFAULT_TARGETS in /meta-phosphor/recipes-phosphor it seems like error and that changes doesn't get in the platform. now instead of overriding have append to the original DEFAULT_TARGETS with bb_append. Testing: The soft links are created properly and the transition change and target mappings are also verified successfully. change-Id: I950e04891cd1438fb24f688231143be966b3a4c9 Signed-off-by: Karthikeyan Pasupathi <pkarthikeyan1509@gmail.com>
Diffstat (limited to 'meta-facebook/recipes-phosphor/state')
-rw-r--r--meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 9699405753..53f7f8ce6e 100644
--- a/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -1,14 +1,15 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-DEFAULT_TARGETS = " \
- multi-user.target.requires/obmc-host-reset@{}.target \
- multi-user.target.wants/phosphor-discover-system-state@{}.service \
+DEFAULT_TARGETS:append = " \
obmc-chassis-poweron@{}.target.wants/chassis-poweron@{}.service \
obmc-chassis-hard-poweroff@{}.target.wants/chassis-poweroff@{}.service \
obmc-host-shutdown@{}.target.wants/host-poweroff@{}.service \
obmc-host-start@{}.target.wants/host-poweron@{}.service \
obmc-host-reboot@{}.target.wants/host-powercycle@{}.service \
"
+DEFAULT_TARGETS:remove = " \
+ obmc-chassis-poweroff@{}.target.requires/obmc-powered-off@{}.service \
+"
SRC_URI:append:greatlakes = " \
file://chassis-poweroff@.service \