summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorKarthikeyan Pasupathi <pkarthikeyan1509@gmail.com>2022-06-22 10:25:04 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-07-22 19:13:52 +0300
commitc77d41d2f06c664862cf536ab9d5dffacd922ee4 (patch)
treee4bce3e06270a27f1092656a1114a5e8964a8274 /meta-facebook
parent3458704d3fbfe080f508ef4574a6d6ff07b696a5 (diff)
downloadopenbmc-c77d41d2f06c664862cf536ab9d5dffacd922ee4.tar.xz
meta-facebook: bb file changes in fb-ipmi-oem.
parsed machine name to meson from bb file to identify and copy the machine-specific JSON to a machine. Tested: Tested and verified with yosemitev2 and tiogapass platform. Signed-off-by: Karthikeyan Pasupathi <pkarthikeyan1509@gmail.com> Change-Id: Ib891a9cef232f981ede61567953888870296a248
Diffstat (limited to 'meta-facebook')
-rwxr-xr-xmeta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
index b7618a1e93..377fe354fd 100755
--- a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
+++ b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
@@ -16,15 +16,14 @@ inherit meson pkgconfig obmc-phosphor-ipmiprovider-symlink
EXTRA_OEMESON="-Dtests=disabled -Dbic=enabled -Dhost-instances='${OBMC_HOST_INSTANCES}'"
EXTRA_OEMESON:remove:yosemitev2 = "-Dbic=enabled"
+EXTRA_OEMESON="-Dmachine='${MACHINE}'"
LIBRARY_NAMES = "libzfboemcmds.so"
HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
-FILES:${PN}:append = " ${datadir}/lcd-debug/post_desc.json"
-FILES:${PN}:append = " ${datadir}/lcd-debug/gpio_desc.json"
-FILES:${PN}:append = " ${datadir}/lcd-debug/cri_sensors.json"
+FILES:${PN}:append = " ${datadir}/lcd-debug/*.json"
FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"