summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorJayashree Dhanapal <jayashree-d@hcl.com>2022-09-22 17:31:32 +0300
committerJayashree Dhanapal <jayashree-d@hcl.com>2022-10-07 16:09:15 +0300
commite01d4ef1f115b9ca73ab7e9234c10fae0b02ddc8 (patch)
treec3949b3e5fb43f057ba00ace4dbd070d45ae2f29 /meta-facebook
parent79373eae439423464e4e08808e493d6dead00fcc (diff)
downloadopenbmc-e01d4ef1f115b9ca73ab7e9234c10fae0b02ddc8.tar.xz
meta-facebook: Add json file for health monitor.
BMC health monitor json file is added for Facebook platform to monitor the CPU, Memory and Storage usage. It will reboot the target, once it exceeds the critical threshold value. Tested: Tested in Facebook YosemiteV3.5 platform Signed-off-by: Jayashree Dhanapal <jayashree-d@hcl.com> Change-Id: Ieb7486b558de087fac7e9acaba1d88771a5b7626
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/recipes-phosphor/health/files/bmc_health_config.json54
-rw-r--r--meta-facebook/recipes-phosphor/health/phosphor-health-monitor_%.bbappend3
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-facebook/recipes-phosphor/health/files/bmc_health_config.json b/meta-facebook/recipes-phosphor/health/files/bmc_health_config.json
new file mode 100644
index 0000000000..0807bae899
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/health/files/bmc_health_config.json
@@ -0,0 +1,54 @@
+{
+ "CPU" : {
+ "Frequency" : 1,
+ "Window_size": 120,
+ "Threshold":
+ {
+ "Critical":
+ {
+ "Value": 90.0,
+ "Log": true,
+ "Target": "reboot.target"
+ },
+ "Warning":
+ {
+ "Value": 80.0,
+ "Log": true,
+ "Target": ""
+ }
+ }
+ },
+ "Memory" : {
+ "Frequency" : 1,
+ "Window_size": 120,
+ "Threshold":
+ {
+ "Critical":
+ {
+ "Value": 85.0,
+ "Log": true,
+ "Target": "reboot.target"
+ }
+ }
+ },
+ "Storage_RW" : {
+ "Path" : "/run/initramfs/rw",
+ "Frequency" : 1,
+ "Window_size": 120,
+ "Threshold":
+ {
+ "Critical":
+ {
+ "Value": 95.0,
+ "Log": true,
+ "Target": ""
+ },
+ "Warning":
+ {
+ "Value": 90.0,
+ "Log": true,
+ "Target": ""
+ }
+ }
+ }
+}
diff --git a/meta-facebook/recipes-phosphor/health/phosphor-health-monitor_%.bbappend b/meta-facebook/recipes-phosphor/health/phosphor-health-monitor_%.bbappend
new file mode 100644
index 0000000000..c0e8f7d565
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/health/phosphor-health-monitor_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+SRC_URI:append = " file://bmc_health_config.json \
+ "