summaryrefslogtreecommitdiff
path: root/meta-fii/meta-mori/recipes-mori
diff options
context:
space:
mode:
authorKyle Nieman <kyle.nieman@fii-na.com>2023-06-30 18:57:34 +0300
committerVivekanand Veeracholan <vveerach@google.com>2023-07-21 22:56:08 +0300
commitaefbb65c6cc444c9f79400de18b66af5f64bbde2 (patch)
tree5ef8726d4dd0ac033f847b397e5b5ddade16ea96 /meta-fii/meta-mori/recipes-mori
parent5350ca2092c4796a24daf2bc270ebcfb7da327e3 (diff)
downloadopenbmc-aefbb65c6cc444c9f79400de18b66af5f64bbde2.tar.xz
meta-fii: meta-mori: Uniform syntax for recipes
Update bitbake recipe format to make uniform with the following rules: 1) Generally bbappends should have layer(mori) overrides 2) Add uniform appending by using "append" instead of "+=" 3) bb files (excluding bbappends) typically should not have "append" phrase except for limited amount of variables (RDEPENDS,DEPENDS,FILES, ...) 4) Wrap lines greater than 80 chars when applicable 5) Switch syntax for long list values over multiple lines to use four-space indent In addition, oe-stylize.py was applied to further refine recipe syntax. Tested: Built successfully. Individual packages were tested for functionality with no notable change. Change-Id: I626c529373805aa696f7c574e10c1617493d4f61 Signed-off-by: Kyle Nieman <kyle.nieman@fii-na.com>
Diffstat (limited to 'meta-fii/meta-mori/recipes-mori')
-rw-r--r--meta-fii/meta-mori/recipes-mori/boot-status-led/mori-boot-status-led.bb22
-rw-r--r--meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bios-update.bb40
-rw-r--r--meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bmc-update.bb26
-rw-r--r--meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-cpld-update.bb50
-rw-r--r--meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-fw.bb26
-rw-r--r--meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-boot.bb25
-rw-r--r--meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-cmd.bb13
7 files changed, 91 insertions, 111 deletions
diff --git a/meta-fii/meta-mori/recipes-mori/boot-status-led/mori-boot-status-led.bb b/meta-fii/meta-mori/recipes-mori/boot-status-led/mori-boot-status-led.bb
index c9b2e9d5e4..4641e7f11e 100644
--- a/meta-fii/meta-mori/recipes-mori/boot-status-led/mori-boot-status-led.bb
+++ b/meta-fii/meta-mori/recipes-mori/boot-status-led/mori-boot-status-led.bb
@@ -1,25 +1,25 @@
SUMMARY = "OpenBMC Mori Boot Status LED Service"
DESCRIPTION = "OpenBMC Mori Boot Status LED Daemon."
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+DEPENDS:append = " systemd"
+PR = "r1"
-inherit systemd
+SRC_URI = " \
+ file://boot-status-led.sh \
+ file://boot-status-led.service \
+"
-DEPENDS += "systemd"
-RDEPENDS:${PN} += "bash"
+SYSTEMD_SERVICE:${PN} = "boot-status-led.service"
-SRC_URI = " file://boot-status-led.sh \
- file://boot-status-led.service \
- "
+inherit systemd
do_install() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/boot-status-led.sh ${D}${bindir}/
-
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/boot-status-led.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/boot-status-led.service \
+ ${D}${systemd_system_unitdir}
}
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "boot-status-led.service"
+RDEPENDS:${PN}:append = " bash"
diff --git a/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bios-update.bb b/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bios-update.bb
index d0c47c055e..cf3cba9f2e 100644
--- a/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bios-update.bb
+++ b/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bios-update.bb
@@ -1,35 +1,31 @@
SUMMARY = "Phosphor OpenBMC Mori BIOS Firmware Upgrade Command"
DESCRIPTION = "Phosphor OpenBMC Mori BIOS Firmware Upgrade Comman Daemon"
-
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+DEPENDS:append = " systemd phosphor-ipmi-flash"
+PROVIDES:append = " virtual/bios-update"
+PR = "r1"
-inherit systemd
-inherit obmc-phosphor-systemd
-
-DEPENDS += "systemd"
-DEPENDS += "phosphor-ipmi-flash"
-RDEPENDS:${PN} += "libsystemd"
-RDEPENDS:${PN} += "mori-fw"
-PROVIDES += "virtual/bios-update"
-RPROVIDES:${PN} += "virtual/bios-update"
-
-FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json"
-
-SRC_URI += " \
+SRC_URI = " \
file://phosphor-ipmi-flash-bios-update.service \
file://config-bios.json \
- "
+"
+
+SYSTEMD_SERVICE:${PN} = "phosphor-ipmi-flash-bios-update.service"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} += " \
- phosphor-ipmi-flash-bios-update.service \
- "
+inherit systemd obmc-phosphor-systemd
do_install () {
install -d ${D}${datadir}/phosphor-ipmi-flash
- install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash
+ install -m 0644 ${WORKDIR}/config-bios.json \
+ ${D}${datadir}/phosphor-ipmi-flash
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service \
+ ${D}${systemd_system_unitdir}
}
+
+RDEPENDS:${PN}:append = " libsystemd mori-fw"
+
+RPROVIDES:${PN}:append = " virtual/bios-update"
+
+FILES:${PN}:append = " ${datadir}/phosphor-ipmi-flash/config-bios.json"
diff --git a/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bmc-update.bb b/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bmc-update.bb
index db74f33964..2b802d06cc 100644
--- a/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bmc-update.bb
+++ b/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-bmc-update.bb
@@ -1,23 +1,21 @@
SUMMARY = "Phosphor OpenBMC Mori BMC Firmware Upgrade Command"
DESCRIPTION = "Phosphor OpenBMC Mori BMC Firmware Upgrade Comman Daemon"
-
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+DEPENDS:append = " phosphor-ipmi-flash"
+PROVIDES:append = " virtual/bmc-update"
+PR = "r1"
-DEPENDS += "phosphor-ipmi-flash"
-RDEPENDS:${PN} += "mori-fw"
-
-RPROVIDES:${PN} += "virtual/bmc-update"
-PROVIDES += "virtual/bmc-update"
-RPROVIDES:${PN} += "virtual/bmc-update"
-FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
-
-SRC_URI += " \
- file://config-bmc.json \
- "
+SRC_URI = "file://config-bmc.json"
do_install () {
install -d ${D}${datadir}/phosphor-ipmi-flash
- install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
+ install -m 0644 ${WORKDIR}/config-bmc.json \
+ ${D}${datadir}/phosphor-ipmi-flash
}
+
+RDEPENDS:${PN}:append = " mori-fw"
+
+RPROVIDES:${PN}:append = " virtual/bmc-update"
+
+FILES:${PN}:append = " ${datadir}/phosphor-ipmi-flash/config-bmc.json"
diff --git a/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-cpld-update.bb b/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-cpld-update.bb
index 7b19f8e14f..1161c75c3d 100644
--- a/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-cpld-update.bb
+++ b/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-cpld-update.bb
@@ -1,41 +1,43 @@
SUMMARY = "Phosphor OpenBMC Mori CPLD Firmware Upgrade Command"
DESCRIPTION = "Phosphor OpenBMC Mori CPLD Firmware Upgrade Comman Daemon"
-
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+DEPENDS:append = " systemd phosphor-ipmi-flash"
+PROVIDES:append = " virtual/cpld-update"
+PR = "r1"
-inherit systemd
-inherit obmc-phosphor-systemd
-
-DEPENDS += "systemd"
-DEPENDS += "phosphor-ipmi-flash"
-RDEPENDS:${PN} += "libsystemd"
-RDEPENDS:${PN} += "mori-fw"
-PROVIDES += "virtual/cpld-update"
-RPROVIDES:${PN} += "virtual/cpld-update"
-
-FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bmccpld.json"
-FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-mbcpld.json"
-
-SRC_URI += " \
+SRC_URI = " \
file://phosphor-ipmi-flash-bmccpld-update.service \
file://phosphor-ipmi-flash-mbcpld-update.service \
file://config-bmccpld.json \
file://config-mbcpld.json \
- "
+"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} += " \
+SYSTEMD_SERVICE:${PN} = " \
phosphor-ipmi-flash-bmccpld-update.service \
phosphor-ipmi-flash-mbcpld-update.service \
- "
+"
+
+inherit systemd obmc-phosphor-systemd
do_install () {
install -d ${D}${datadir}/phosphor-ipmi-flash
- install -m 0644 ${WORKDIR}/config-bmccpld.json ${D}${datadir}/phosphor-ipmi-flash
- install -m 0644 ${WORKDIR}/config-mbcpld.json ${D}${datadir}/phosphor-ipmi-flash
+ install -m 0644 ${WORKDIR}/config-bmccpld.json \
+ ${D}${datadir}/phosphor-ipmi-flash
+ install -m 0644 ${WORKDIR}/config-mbcpld.json \
+ ${D}${datadir}/phosphor-ipmi-flash
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmccpld-update.service ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-mbcpld-update.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmccpld-update.service \
+ ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-mbcpld-update.service \
+ ${D}${systemd_system_unitdir}
}
+
+RDEPENDS:${PN}:append = " libsystemd mori-fw"
+
+RPROVIDES:${PN}:append = " virtual/cpld-update"
+
+FILES:${PN}:append = " \
+ ${datadir}/phosphor-ipmi-flash/config-bmccpld.json \
+ ${datadir}/phosphor-ipmi-flash/config-mbcpld.json \
+"
diff --git a/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-fw.bb b/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-fw.bb
index 272106a6ae..71c69b0b2c 100644
--- a/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-fw.bb
+++ b/meta-fii/meta-mori/recipes-mori/mori-fw-utility/mori-fw.bb
@@ -1,36 +1,30 @@
SUMMARY = "Phosphor OpenBMC mori Firmware Upgrade Command"
DESCRIPTION = "Phosphor OpenBMC mori Firmware Upgrade Comman Daemon"
-
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit systemd
-inherit obmc-phosphor-systemd
-
-DEPENDS += "systemd"
-DEPENDS += "phosphor-ipmi-flash"
-RDEPENDS:${PN} += "libsystemd"
-RDEPENDS:${PN} += "bash"
+DEPENDS:append = " systemd phosphor-ipmi-flash"
+PR = "r1"
SRC_URI = " \
file://mori-fw.sh \
file://mori-fw-ver.service \
file://mori-fw-ver.sh \
file://mori-lib.sh \
- "
+"
+
+SYSTEMD_SERVICE:${PN} = "mori-fw-ver.service"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = " \
- mori-fw-ver.service \
- "
+inherit systemd obmc-phosphor-systemd
do_install () {
install -d ${D}${sbindir}
install -d ${D}${libexecdir}/${PN}
install -m 0755 ${WORKDIR}/mori-fw.sh ${D}${sbindir}/mori-fw.sh
- install -m 0755 ${WORKDIR}/mori-fw-ver.sh ${D}${libexecdir}/${PN}/mori-fw-ver.sh
+ install -m 0755 ${WORKDIR}/mori-fw-ver.sh \
+ ${D}${libexecdir}/${PN}/mori-fw-ver.sh
install -m 0755 ${WORKDIR}/mori-lib.sh ${D}${libexecdir}/${PN}/mori-lib.sh
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/mori-fw-ver.service ${D}${systemd_system_unitdir}
}
+
+RDEPENDS:${PN}:append = " libsystemd bash"
diff --git a/meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-boot.bb b/meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-boot.bb
index bceca8d935..acf0c03f17 100644
--- a/meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-boot.bb
+++ b/meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-boot.bb
@@ -1,30 +1,25 @@
SUMMARY = "Phosphor OpenBMC Mori System Power Control Service"
DESCRIPTION = "Phosphor OpenBMC Mori System Power Control Daemon"
-
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit systemd
-inherit obmc-phosphor-systemd
-
-DEPENDS += "systemd"
-RDEPENDS:${PN} += "libsystemd"
-RDEPENDS:${PN} += "bash"
+DEPENDS:append = " systemd"
+PR = "r1"
SRC_URI = " \
file://init_once.sh \
file://host-powerctrl.service \
- "
+"
+
+SYSTEMD_SERVICE:${PN} = "host-powerctrl.service"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = " \
- host-powerctrl.service \
- "
+inherit systemd obmc-phosphor-systemd
do_install () {
install -d ${D}${libexecdir}/${PN}
install -m 0755 ${WORKDIR}/init_once.sh ${D}${libexecdir}/${PN}
install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/host-powerctrl.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/host-powerctrl.service \
+ ${D}${systemd_unitdir}/system
}
+
+RDEPENDS:${PN}:append = " libsystemd bash"
diff --git a/meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-cmd.bb b/meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-cmd.bb
index 34d9e04597..3fb90a20df 100644
--- a/meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-cmd.bb
+++ b/meta-fii/meta-mori/recipes-mori/mori-sys-utility/mori-cmd.bb
@@ -1,19 +1,14 @@
SUMMARY = "Phosphor OpenBMC Mori System Command"
DESCRIPTION = "Phosphor OpenBMC Mori System Command Daemon"
-
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+PR = "r1"
-RDEPENDS:${PN} += "bash"
-
-SRC_URI = " \
- file://mori.sh \
- "
-
-SYSTEMD_PACKAGES = "${PN}"
+SRC_URI = "file://mori.sh"
do_install () {
install -d ${D}${sbindir}
install -m 0755 ${WORKDIR}/mori.sh ${D}${sbindir}/mori.sh
}
+
+RDEPENDS:${PN}:append = " bash"