summaryrefslogtreecommitdiff
path: root/meta-fii
diff options
context:
space:
mode:
authorKyle Nieman <kyle.nieman@fii-na.com>2023-05-15 17:53:07 +0300
committerVivekanand Veeracholan <vveerach@google.com>2023-07-11 20:20:23 +0300
commit6b203328f54f674dc36319fe0c2248c715508c02 (patch)
tree2363219ff6cf2e544e87b983a2d05080ec43a03e /meta-fii
parente6c34c0667cfce0c535fe6451dc3e66d077413c0 (diff)
downloadopenbmc-6b203328f54f674dc36319fe0c2248c715508c02.tar.xz
meta-fii: meta-mori: Remove watchdog support
Remove watchdog support added in https://gerrit.openbmc.org/c/openbmc/openbmc/+/57895 Change-Id: I370de442f7b4b15d1be48717f2e688363c102d87 Signed-off-by: Kyle Nieman <kyle.nieman@fii-na.com>
Diffstat (limited to 'meta-fii')
-rw-r--r--meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog/obmc/watchdog/host08
-rw-r--r--meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog.service21
-rw-r--r--meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend9
3 files changed, 0 insertions, 38 deletions
diff --git a/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog/obmc/watchdog/host0 b/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog/obmc/watchdog/host0
deleted file mode 100644
index 18ec767641..0000000000
--- a/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog/obmc/watchdog/host0
+++ /dev/null
@@ -1,8 +0,0 @@
-DEVPATH=/xyz/openbmc_project/watchdog/host0
-SERVICE=xyz.openbmc_project.Watchdog
-UNIT_HARD_RESET=ampere-host-power-cycle.service
-UNIT_POWER_OFF=ampere-chassis-poweroff.service
-UNIT_POWER_CYCLE=ampere-chassis-powercycle.service
-FALLBACK_ACTION=xyz.openbmc_project.State.Watchdog.Action.PowerCycle
-FALLBACK_INTERVAL=10800000
-MIN_INTERVAL=60000
diff --git a/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog.service b/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog.service
deleted file mode 100644
index 003f479223..0000000000
--- a/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog.service
+++ /dev/null
@@ -1,21 +0,0 @@
-[Unit]
-Description=Phosphor Watchdog
-
-[Service]
-EnvironmentFile={envfiledir}/obmc/watchdog/host0
-
-ExecStart=phosphor-watchdog --service=${{SERVICE}} --path=${{DEVPATH}} --watch_postcodes \
- --continue --fallback_always --min_interval=${{MIN_INTERVAL}} \
- --fallback_action=${{FALLBACK_ACTION}} --fallback_interval=${{FALLBACK_INTERVAL}} \
- --action_target=xyz.openbmc_project.State.Watchdog.Action.HardReset=${{UNIT_HARD_RESET}} \
- --action_target=xyz.openbmc_project.State.Watchdog.Action.PowerOff=${{UNIT_POWER_OFF}} \
- --action_target=xyz.openbmc_project.State.Watchdog.Action.PowerCycle=${{UNIT_POWER_CYCLE}} \
-
-# This should use state manager instead of the service files currently defined
-
-SyslogIdentifier=phosphor-watchdog
-BusName=xyz.openbmc_project.Watchdog
-Type=dbus
-
-[Install]
-WantedBy=basic.target
diff --git a/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend b/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
deleted file mode 100644
index 6a70555723..0000000000
--- a/meta-fii/meta-mori/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
-FILESEXTRAPATHS:prepend:mori := "${THISDIR}/${PN}:"
-SYSTEMD_ENVIRONMENT_FILE:${PN}:append:mori = " obmc/watchdog/host0"
-
-SYSTEMD_LINK:${PN}:remove:mori = "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"
-SYSTEMD_LINK:${PN}:remove:mori = "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
-# Remove the override to keep service running after DC cycle
-SYSTEMD_OVERRIDE_${PN}:remove:mori = "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
-SYSTEMD_SERVICE:${PN}:mori = " phosphor-watchdog.service \
- "