summaryrefslogtreecommitdiff
path: root/meta-google/recipes-core/os-release
diff options
context:
space:
mode:
authorTom Tung <shes050117@gmail.com>2023-05-17 14:11:26 +0300
committerTom Tung <shes050117@gmail.com>2023-05-18 03:20:16 +0300
commit7f9f244771161e8c99befd153344f48986c7ed45 (patch)
tree2e3f3714222293aef7c52284df29c277fc958bef /meta-google/recipes-core/os-release
parentc28937836f712db07267985b557eedf0924b09ae (diff)
downloadopenbmc-7f9f244771161e8c99befd153344f48986c7ed45.tar.xz
meta-google: os-release: add GBMC_TARGET_MACHINE
Tested: Check `tmp/work/all-openbmc-linux/os-release/1.0-r0/package/etc/os-release` and the `GBMC_TARGET_MACHINE` has the value as expected. Change-Id: I8b2d2b2aefcd3310f36404f97af0d03f840f64ad Signed-off-by: Tom Tung <shes050117@gmail.com>
Diffstat (limited to 'meta-google/recipes-core/os-release')
-rw-r--r--meta-google/recipes-core/os-release/os-release.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-google/recipes-core/os-release/os-release.bbappend b/meta-google/recipes-core/os-release/os-release.bbappend
index 635f7c5ae4..0d4904c9be 100644
--- a/meta-google/recipes-core/os-release/os-release.bbappend
+++ b/meta-google/recipes-core/os-release/os-release.bbappend
@@ -8,4 +8,6 @@ python() {
}
IMAGE_TYPE = "${GBMC_CONFIG}"
-OS_RELEASE_FIELDS:append:gbmc = " BUILD_MEMO IMAGE_TYPE"
+GBMC_TARGET_MACHINE ?= "${MACHINE}"
+
+OS_RELEASE_FIELDS:append:gbmc = " BUILD_MEMO IMAGE_TYPE GBMC_TARGET_MACHINE"