summaryrefslogtreecommitdiff
path: root/meta-google/recipes-extended
diff options
context:
space:
mode:
authorkasunath <kasunath@google.com>2022-08-10 21:08:14 +0300
committerJosh Lehan <krellan@google.com>2022-09-10 03:33:28 +0300
commit951f1aabea4c8683cda113e743b68ad2dfd57fa8 (patch)
tree04a67303694dd7b403ae231f6fc6f0b754500404 /meta-google/recipes-extended
parent68a709f467b1656dea5588c8d56fa8bf1f02c092 (diff)
downloadopenbmc-951f1aabea4c8683cda113e743b68ad2dfd57fa8.tar.xz
meta-google: Remove cracklib from image and libpam dependency
The package "cracklib" is not needed. Ideally in the future we will start using Google GLOME. The "libpam" library depends on cracklib, so override the libpam recipe also, so that it no longer depends on cracklib. Tested: This has been tested locally on our local product, which uses OpenBMC, and it appeared to work just fine for us. Signed-off-by: Kasun Athukorala <kasunath@google.com> Change-Id: I0d7714766a2e14151f00f6582abee78dee43614d Signed-off-by: Josh Lehan <krellan@google.com>
Diffstat (limited to 'meta-google/recipes-extended')
-rw-r--r--meta-google/recipes-extended/pam/libpam_%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-google/recipes-extended/pam/libpam_%.bbappend b/meta-google/recipes-extended/pam/libpam_%.bbappend
new file mode 100644
index 0000000000..287dab7b14
--- /dev/null
+++ b/meta-google/recipes-extended/pam/libpam_%.bbappend
@@ -0,0 +1,15 @@
+# Remove cracklib from PAM, to avoid breaking PAM and further dependencies
+# This allows cracklib to be neatly severed from the system.
+
+EXTRA_OECONF:append:gbmc = " --disable-cracklib"
+
+DEPENDS:remove:gbmc = "cracklib"
+
+RDEPENDS:${PN}-runtime:remove:gbmc = "pam-plugin-cracklib-suffix"
+
+RDEPENDS:${PN}-xtests:remove:gbmc = "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix}"
+
+do_install:append:gbmc() {
+ # Remove reference to cracklib library from PAM config file
+ sed -i '/pam_cracklib.so/d' ${D}${sysconfdir}/pam.d/common-password
+}