summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/networking/gbmc-bridge.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2022-05-10 01:24:22 +0300
committerWilliam A. Kennington III <wak@google.com>2022-05-27 02:02:20 +0300
commitd230e86a920ba1440e6299a60f0442ceb610d500 (patch)
treef9ca0e3f85f289f1b0c59ff0a6fd887cdb8fa622 /meta-google/recipes-google/networking/gbmc-bridge.bb
parent83f9416eee4289606fb6a297f095cf583a875e7f (diff)
downloadopenbmc-d230e86a920ba1440e6299a60f0442ceb610d500.tar.xz
meta-google: gbmc-bridge: Add DHCP coalesced powercycle
This makes it possible to perform to coalesce multiple powercycles into a single one. Change-Id: I748219a037e38b617b8d662eff498fd3b37acbb6 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/networking/gbmc-bridge.bb')
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index 57f78ea4ac..850b14a237 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -21,6 +21,7 @@ SRC_URI += " \
file://gbmc-br-gw-src.sh \
file://gbmc-br-nft.sh \
file://gbmc-br-dhcp.sh \
+ file://50-gbmc-psu-hardreset.sh \
file://gbmc-br-dhcp.service \
file://gbmc-br-dhcp-term.sh \
file://gbmc-br-dhcp-term.service \
@@ -28,6 +29,7 @@ SRC_URI += " \
FILES:${PN}:append = " \
${datadir}/gbmc-ip-monitor \
+ ${datadir}/gbmc-br-dhcp \
${systemd_unitdir}/network \
${sysconfdir}/nftables \
${sysconfdir}/avahi/services \
@@ -109,6 +111,8 @@ do_install() {
install -m0644 ${WORKDIR}/gbmc-br-ensure-ra.service ${D}${systemd_system_unitdir}/
install -m0644 ${WORKDIR}/gbmc-br-dhcp.service ${D}${systemd_system_unitdir}/
install -m0644 ${WORKDIR}/gbmc-br-dhcp-term.service ${D}${systemd_system_unitdir}/
+ install -d -m0755 ${D}${datadir}/gbmc-br-dhcp
+ install -m0644 ${WORKDIR}/50-gbmc-psu-hardreset.sh ${D}${datadir}/gbmc-br-dhcp/
}
do_rm_work:prepend() {