summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google
diff options
context:
space:
mode:
authorYuxiao Zhang <yuxiaozhang@google.com>2023-12-13 04:33:51 +0300
committerYuxiao Zhang <yuxiaozhang@google.com>2023-12-15 21:18:11 +0300
commit4f73a7874014eeab4833ad5074f1e51b206a8d92 (patch)
tree520c0f32529774354de5014e9206cf092769dd4b /meta-google/recipes-google
parent1e52b833df3ffcfc4b83e114ee91d75f5e98c69e (diff)
downloadopenbmc-4f73a7874014eeab4833ad5074f1e51b206a8d92.tar.xz
meta-google: add host-gpio-monitor recipe
Change-Id: Ibe6172ceb44024d7229b9dfda7b9df2a8f98a8d6 Signed-off-by: Yuxiao Zhang <yuxiaozhang@google.com>
Diffstat (limited to 'meta-google/recipes-google')
-rw-r--r--meta-google/recipes-google/bare-metal-gpio-monitor/bare-metal-gpio-monitor_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-google/recipes-google/bare-metal-gpio-monitor/bare-metal-gpio-monitor_git.bb b/meta-google/recipes-google/bare-metal-gpio-monitor/bare-metal-gpio-monitor_git.bb
new file mode 100644
index 0000000000..a2242849de
--- /dev/null
+++ b/meta-google/recipes-google/bare-metal-gpio-monitor/bare-metal-gpio-monitor_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Monitor host GPIO in bare metal mode"
+DESCRIPTION = "Monitor host GPIO in bare metal mode"
+GOOGLE_MISC_PROJ = "bare-metal-host-monitor"
+
+require ../google-misc/google-misc.inc
+
+inherit pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN}:append = " \
+ host-gpio-monitor.service \
+ "
+
+DEPENDS:append = " \
+ sdbusplus \
+ stdplus \
+ phosphor-logging \
+ "
+
+RDEPENDS:${PN}:append = " \
+ bare-metal-active \
+ "