summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google
diff options
context:
space:
mode:
authorLuke Granger-Brown <lukegb@google.com>2023-08-22 21:23:19 +0300
committerlukegb <lukegb@google.com>2023-08-25 17:31:35 +0300
commit785c780867e27dd1d1dd2d05a9d18f6bdf5a557f (patch)
tree7556b4c68cddedc462f118cbbe008c19d34d0ef0 /meta-google/recipes-google
parent9bb4ce5401f401e9a4e96a158c772d27a9ea8e8a (diff)
downloadopenbmc-785c780867e27dd1d1dd2d05a9d18f6bdf5a557f.tar.xz
meta-google: glome: remove from layer
glome is now in the meta-security layer and shouldn't(*) be included here. glome-config is also removed; downstreams should bbappend glome to overwrite /etc/glome/config. (*) https://lore.kernel.org/all/Ys6zBXR+8AP3wjYG@heinlein.stwcx.org.github.beta.tailscale.net/ Tested: Added meta-security layer to a build and tested downstream BMC build. Link: https://gerrit.openbmc.org/id/I8e96a5c15a277c343ca38c32ad5b987944642008 Change-Id: I8e96a5c15a277c343ca38c32ad5b987944642008 Signed-off-by: Luke Granger-Brown <lukegb@google.com>
Diffstat (limited to 'meta-google/recipes-google')
-rw-r--r--meta-google/recipes-google/console/glome-config.bb39
-rw-r--r--meta-google/recipes-google/console/glome-config/config.in8
-rw-r--r--meta-google/recipes-google/console/glome_git.bb29
3 files changed, 0 insertions, 76 deletions
diff --git a/meta-google/recipes-google/console/glome-config.bb b/meta-google/recipes-google/console/glome-config.bb
deleted file mode 100644
index be3612d398..0000000000
--- a/meta-google/recipes-google/console/glome-config.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-SUMMARY = "Glome Config"
-DESCRIPTION = "Glome config file provides a glome config file"
-PR = "r1"
-
-# This is required to replace the glome/config that is removed in glome_git.bb
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-# Example Privkey: A0F1D0A0CB254839D04637F567325B850B5174850B129E811F5E203A42CC3B6C
-GLOME_PUBLIC_KEY ?= "AC11D4582261F2D05CDDE1BD94383393D26C5C269642EE26D7EABD1EADC03C14"
-GLOME_KEY_VERSION ?= "4"
-GLOME_URL_PREFIX ?= "http://example-glome-service/"
-
-SRC_URI = "file://config.in"
-
-do_install:append() {
- if [ -z '${GLOME_PUBLIC_KEY}' ]; then
- echo 'Missing GLOME_PUBLIC_KEY' >&2
- exit 1
- fi
- if [ -z '${GLOME_KEY_VERSION}' ]; then
- echo 'Missing GLOME_KEY_VERSION' >&2
- exit 1
- fi
- if [ -z '${GLOME_URL_PREFIX}' ]; then
- echo 'Missing GLOME_URL_PREFIX' >&2
- exit 1
- fi
-
- sed ${WORKDIR}/config.in \
- -e 's#@PUBLIC_KEY@#${GLOME_PUBLIC_KEY}#' \
- -e 's#@KEY_VERSION@#${GLOME_KEY_VERSION}#' \
- -e 's#@URL_PREFIX@#${GLOME_URL_PREFIX}#' \
- > ${WORKDIR}/config
-
- install -d ${D}${sysconfdir}/glome
- install -m 0644 ${WORKDIR}/config ${D}${sysconfdir}/glome
-}
diff --git a/meta-google/recipes-google/console/glome-config/config.in b/meta-google/recipes-google/console/glome-config/config.in
deleted file mode 100644
index 291f6a57fb..0000000000
--- a/meta-google/recipes-google/console/glome-config/config.in
+++ /dev/null
@@ -1,8 +0,0 @@
-# This is the configuration file for serial console authentication with glome.
-# /usr/sbin/glome-login tries to read this file on startup at its canonical
-# location /etc/glome/config.
-
-[service]
-key = @PUBLIC_KEY@
-key-version = @KEY_VERSION@
-url-prefix = @URL_PREFIX@
diff --git a/meta-google/recipes-google/console/glome_git.bb b/meta-google/recipes-google/console/glome_git.bb
deleted file mode 100644
index 8940a83644..0000000000
--- a/meta-google/recipes-google/console/glome_git.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "GLOME Login Client"
-DESCRIPTION = "GLOME login is first application of the GLOME protocol. It is used to authorize serial console access to Linux machines"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-inherit meson pkgconfig
-
-DEPENDS += " \
- openssl \
- glome-config \
- "
-
-S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
-SRCREV = "978ad9fb165f1e382c875f2ce08a1fc4f2ddcf1b"
-
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
-PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
-
-EXTRA_OEMESON = "-Dtests=false"
-
-# remove the default glome config so it can be overridden by `glome-config`
-do_install:append() {
- rm -f ${D}${sysconfdir}/glome/config
-}