summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2023-08-28 23:05:57 +0300
committerWilliam A. Kennington III <wak@google.com>2023-08-28 23:15:16 +0300
commitbf4e27c3408955c214000108001e92c308c1861f (patch)
treeca092530c42dad67512e147cf2c0d02e5dd384a0 /meta-google/recipes-google
parent6129ad0d650a1320b954459aa293cf010761125d (diff)
downloadopenbmc-bf4e27c3408955c214000108001e92c308c1861f.tar.xz
meta-google: gbmc-bridge: Deprecate hardcoded addresses
These addresses should not be used by default for traffic on the interface, as we may have multiple BMCs using the same hardcoded address WRT legacy applications. We want multiple BMCs of the same type to be able to coexist if they have unique addresses and right now they are not correctly preferring these addresses. Change-Id: I0d02cbf63b54f2464ae889ea773e032da0e9b650 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google')
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge.bb3
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge/-bmc-gbmcbr.network.in2
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index 3245eb251d..50cf0b5afc 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -97,7 +97,8 @@ do_install() {
if [ ! -z "${GBMC_BR_MAC_ADDR}" ]; then
sfx='${@mac_to_eui64(GBMC_BR_MAC_ADDR)}'
- addr="Address=${GBMC_ULA_PREFIX}:$sfx/64\nAddress=fe80::$sfx/64"
+ addr="[Address]\nAddress=${GBMC_ULA_PREFIX}:$sfx/64\nPreferredLifetime=0\n"
+ addr+="[Address]\nAddress=fe80::$sfx/64\nPreferredLifetime=0"
sed -i "s,@ADDR@,$addr," ${WORKDIR}/-bmc-gbmcbr.network.in
else
sed -i '/@ADDR@/d' ${WORKDIR}/-bmc-gbmcbr.network.in
diff --git a/meta-google/recipes-google/networking/gbmc-bridge/-bmc-gbmcbr.network.in b/meta-google/recipes-google/networking/gbmc-bridge/-bmc-gbmcbr.network.in
index feaebda02f..d77557e8e3 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge/-bmc-gbmcbr.network.in
+++ b/meta-google/recipes-google/networking/gbmc-bridge/-bmc-gbmcbr.network.in
@@ -1,13 +1,13 @@
[Match]
Name=gbmcbr
[Network]
-@ADDR@
DHCP=false
IPv6AcceptRA=true
LLMNR=true
MulticastDNS=true
LinkLocalAddressing=ipv6
IPv6PrefixDelegation=yes
+@ADDR@
[IPv6AcceptRA]
DHCPv6Client=false
RouteMetric=1056