summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/ipmi
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2023-10-19 02:11:40 +0300
committerWilliam A. Kennington III <wak@google.com>2023-10-27 00:46:50 +0300
commitcfcec1f6069ae5da2677b66041a1ccc9fec498da (patch)
treeee21811fdcefc5bf5d9f0b771a29aa093e539027 /meta-google/recipes-phosphor/ipmi
parentbff90315fe326067ee38bf0deda829c7c3da3aaf (diff)
downloadopenbmc-cfcec1f6069ae5da2677b66041a1ccc9fec498da.tar.xz
meta-google: treewide: Parameterize NCSI channel
Most platforms want to use 1 as has been the implicit standard. However, this is not required and might be changed for some machines. This makes it easy to change via a machine configuration variable. Change-Id: I5dff5dfb1c97bab531042fd364114f320d3ebe42 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-phosphor/ipmi')
-rw-r--r--meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend b/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
index 1afe115502..121562af93 100644
--- a/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
+++ b/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -8,6 +8,7 @@ SRC_URI:append:gbmc = " \
DEPENDS:append:gbmc = " jq-native"
GBMCBR_IPMI_CHANNEL ?= "11"
+GBMC_NCSI_IPMI_CHANNEL ??= "1"
ENTITY_MAPPING ?= "default"
@@ -43,7 +44,7 @@ do_install:append:gbmc() {
fi
gbmc_add_channel ${GBMCBR_IPMI_CHANNEL} gbmcbr
if [ -n "${GBMC_NCSI_IF_NAME}" ]; then
- gbmc_add_channel 1 ${GBMC_NCSI_IF_NAME}
+ gbmc_add_channel ${GBMC_NCSI_IPMI_CHANNEL} ${GBMC_NCSI_IF_NAME}
fi
# Set entity-map.json to empty json for gBMC by default.