summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor
diff options
context:
space:
mode:
authorLeo Tu <leotu@google.com>2022-09-05 08:50:56 +0300
committerleotu <leotu@google.com>2022-09-10 02:28:48 +0300
commit68a709f467b1656dea5588c8d56fa8bf1f02c092 (patch)
treea673655161bc3bc751aa969aeb2e10cc3fe6c6f0 /meta-google/recipes-phosphor
parent92b42cb35d755f8cfe6c17d403711a536e0f0721 (diff)
downloadopenbmc-68a709f467b1656dea5588c8d56fa8bf1f02c092.tar.xz
meta-google: remove glome-config from glome's RDEPENDS
glome-config only provides the config file for glome. It is more appropriate to decouple them by adding glome-config to OBMC_IMAGE_EXTRA_INSTALL in the meta-google layer. Then when glome is migrated to another meta layer, it won't need this RDEPENDS. (This is a follow-up of https://gerrit.openbmc.org/c/openbmc/openbmc/+/56618/) Also add glome-login to OBMC_IMAGE_EXTRA_INSTALL since it is also needed. Tested: Built an image and run it on a real machine. Verified that glome is enabled and the generated link gave a valid password. Signed-off-by: Leo Tu <leotu@google.com> Change-Id: I985670454f4749c5297261ec81466fed9cdc5c40
Diffstat (limited to 'meta-google/recipes-phosphor')
-rw-r--r--meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 88a40d1ffb..570493beea 100644
--- a/meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -3,6 +3,9 @@ OBMC_IMAGE_EXTRA_INSTALL:append = " google-ipmi-i2c"
OBMC_IMAGE_EXTRA_INSTALL:append = " phosphor-ipmi-blobs"
OBMC_IMAGE_EXTRA_INSTALL:append = " phosphor-ipmi-ethstats"
OBMC_IMAGE_EXTRA_INSTALL:append = " phosphor-ipmi-flash"
+OBMC_IMAGE_EXTRA_INSTALL:append = \
+ '${@bb.utils.contains_any("MACHINE_FEATURES", "glome", \
+ " glome-config glome-login", "", d)}'
# Google BMC (gBMC) specific installs
OBMC_IMAGE_EXTRA_INSTALL:append:gbmc = " iproute2 iproute2-ss"