summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2022-02-09 03:24:42 +0300
committerWilliam A. Kennington III <wak@google.com>2022-02-23 19:36:43 +0300
commit0decde15275b12117738dc3716647d77b5faf7b5 (patch)
tree54e37a3d83b7f39aedf040b812ac3871feceaaf2 /meta-google
parent9915b6fe33250e72244fbdfa83ae89d900b78ebb (diff)
downloadopenbmc-0decde15275b12117738dc3716647d77b5faf7b5.tar.xz
meta-google: dhcp-done: Add recipe
This will be picked up by the gbmc-bridge DHCP process in another change. Change-Id: Id80688d0d7a7872bca2eec70c31468a483f72feb Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/networking/dhcp-done/50-dhcp-done.rules5
-rw-r--r--meta-google/recipes-google/networking/dhcp-done_git.bb22
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-google/recipes-google/networking/dhcp-done/50-dhcp-done.rules b/meta-google/recipes-google/networking/dhcp-done/50-dhcp-done.rules
new file mode 100644
index 0000000000..f84b6c0561
--- /dev/null
+++ b/meta-google/recipes-google/networking/dhcp-done/50-dhcp-done.rules
@@ -0,0 +1,5 @@
+table inet filter {
+ chain gbmc_br_pub_input {
+ tcp dport 23 accept
+ }
+}
diff --git a/meta-google/recipes-google/networking/dhcp-done_git.bb b/meta-google/recipes-google/networking/dhcp-done_git.bb
new file mode 100644
index 0000000000..5732033153
--- /dev/null
+++ b/meta-google/recipes-google/networking/dhcp-done_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Google DHCP completion daemon"
+DESCRIPTION = "Google DHCP completion daemon"
+GOOGLE_MISC_PROJ = "dhcp-done"
+
+require ../google-misc/google-misc.inc
+
+inherit systemd
+
+SYSTEMD_SERVICE:${PN} += "dhcp-done.service"
+
+DEPENDS += " \
+ sdeventplus \
+ stdplus \
+ "
+
+SRC_URI += "file://50-dhcp-done.rules"
+FILES:${PN} += "${sysconfdir}/nftables"
+do_install:append() {
+ nftables_dir=${D}${sysconfdir}/nftables
+ install -d -m0755 "$nftables_dir"
+ install -m0644 ${WORKDIR}/50-dhcp-done.rules $nftables_dir/
+}