summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2022-02-13 02:36:05 +0300
committerWilliam A. Kennington III <wak@google.com>2022-02-23 20:19:53 +0300
commit7e2d05d7ff211c09e482758a448d7e4a604192b6 (patch)
tree6aab9e9f58cfeebd02063b6211b1cf8572bfa2c4 /meta-google
parentfe08f02e903e6f2d8b03767b9238ad148a3f539a (diff)
downloadopenbmc-7e2d05d7ff211c09e482758a448d7e4a604192b6.tar.xz
meta-google: gbmc-bridge: Run service when DHCP completes
This makes it possible for our installation service to determine when the BMC is ready to continue after DHCP. Change-Id: I62f31c39a9d5849d18f81ab58c88e9e5ef4b9737 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge.bb1
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh4
2 files changed, 5 insertions, 0 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index 509d871d9b..bc3b51367f 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -33,6 +33,7 @@ FILES:${PN}:append = " \
RDEPENDS:${PN}:append = " \
bash \
+ dhcp-done \
gbmc-ip-monitor \
mstpd-mstpd \
network-sh \
diff --git a/meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh b/meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh
index e2701d4588..1a6c71af1b 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh
+++ b/meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh
@@ -98,4 +98,8 @@ EOF
fi
gbmc_br_dhcp_run_hooks || exit
+
+ # Ensure that the installer knows we have completed processing DHCP by
+ # running a service that reports completion
+ systemctl start dhcp-done --no-block
fi