summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2022-07-09 00:39:13 +0300
committerWilliam A. Kennington III <wak@google.com>2022-07-09 01:03:12 +0300
commit9c5d7faa38873025141e211212f33aab00fa0eb0 (patch)
tree91e65e78a0f1761cb993a431ab00c4953013d3d3 /meta-google
parent5f98f6d52c4cbb6852e88f0814fc6449ef44ef18 (diff)
downloadopenbmc-9c5d7faa38873025141e211212f33aab00fa0eb0.tar.xz
glome: Bump 02f7d272..978ad9fb
Copybara-Service (1): Merge pull request #108 from l9i:l9i-fix-pylint Markus Rudy (6): Enforce some code standards when compiling C. (#110) Merge pull request #112 from vvidic/ini-parser Merge pull request #114 from vvidic/docker Merge pull request #111 from vvidic/login-pam Correctly free the message buffer in case of an snprintf error Merge pull request #118 from vvidic/newline Philipp Kern (10): Merge pull request #106 from vvidic/cli-login Merge pull request #113 from vvidic/addrinfo-free Merge pull request #119 from vvidic/option-tests Support compilation with both old and new pam_wrapper Run the C compilation presubmit on Debian stable and testing Merge pull request #123 from pkern/pamtest-fix Merge pull request #124 from pkern/debian-presubmit Merge pull request #128 from google/l9i/fakepassword Merge pull request #129 from vvidic/getopt-long Merge pull request #130 from vvidic/pam-options Piotr Lewandowski (7): pyglome: more consise exception messages Fix the tag length check exception message Use comma, not semicolon for intervals notation pam_glome: support fake passwords from OpenSSH Apply clang-format Apply clang-format, Google style Use an error message matching the rest of the file Valentin Vidic (9): Add login command to glome CLI (#91) Free struct addrinfo allocated by getaddrinfo Implement a simple INI parser for config files Create a Docker container for testing glome-login and PAM module Use the same auth function for PAM and login binary Make tests optional using a global meson option Fix handling of long authorization codes Add support for long and config options Sync PAM config options names with the rest of the code. Change-Id: I07674f198f1a00ae7bff4feb99a01db940e7d7ad Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/console/glome_git.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-google/recipes-google/console/glome_git.bb b/meta-google/recipes-google/console/glome_git.bb
index 23623d7868..42dcbda25e 100644
--- a/meta-google/recipes-google/console/glome_git.bb
+++ b/meta-google/recipes-google/console/glome_git.bb
@@ -8,14 +8,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
inherit meson pkgconfig
-DEPENDS += " \
- openssl \
- glib-2.0 \
- "
+DEPENDS += "openssl"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
-SRCREV = "02f7d2722a2eb303f1f02d0c2ce97a65f8273662"
+SRCREV = "978ad9fb165f1e382c875f2ce08a1fc4f2ddcf1b"
FILES_${PN} += "${libdir}/security"
@@ -23,4 +20,4 @@ PACKAGECONFIG ??= ""
PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
-EXTRA_OEMESON = "-Dtests=disabled"
+EXTRA_OEMESON = "-Dtests=false"