summaryrefslogtreecommitdiff
path: root/meta-ibm/conf/layer.conf
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2023-06-30 23:46:00 +0300
committerAndrew Geissler <geissonator@yahoo.com>2023-07-18 17:28:06 +0300
commitb5c22690c606423fcf2a79cfd691f174f49b08ee (patch)
tree42a8ad6c0f3909dbd2857405eba97727da9f6685 /meta-ibm/conf/layer.conf
parentd8edd104e2ed89b51a5adebab05724960bd9dd55 (diff)
downloadopenbmc-b5c22690c606423fcf2a79cfd691f174f49b08ee.tar.xz
meta-ibm: only use openpower bbappend when including layer
There is a desire to add non-openpower systems to the meta-ibm layer. To do that, need to ensure the bbappend files that are appending to openpower recipes are only included if the machine being built includes the meta-openpower layer. Tested: - Confirmed a system not including meta-openpower builds ok with this - Confirmed p10bmc still uses the bbappend files Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I32a08e9f20a20152d51c77cdfca6bbc15b5e93d4
Diffstat (limited to 'meta-ibm/conf/layer.conf')
-rw-r--r--meta-ibm/conf/layer.conf6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-ibm/conf/layer.conf b/meta-ibm/conf/layer.conf
index 763f4f5838..d8478bbaf2 100644
--- a/meta-ibm/conf/layer.conf
+++ b/meta-ibm/conf/layer.conf
@@ -8,3 +8,9 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "ibm-layer"
BBFILE_PATTERN_ibm-layer := "^${LAYERDIR}/"
LAYERSERIES_COMPAT_ibm-layer = "langdale mickledore"
+
+# Only bring in meta-openpower bbappend files if meta-openpower is
+# included in the layer
+BBFILES_DYNAMIC += "\
+ openpower-layer:${LAYERDIR}/dynamic-layers/meta-openpower/recipes-*/*/*.bbappend \
+"