summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-fsp2
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-01-25 00:55:09 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-01-25 19:37:00 +0300
commitbb99d22ecef61f3af21290b1e1ead3083f25d20f (patch)
treeaa8d74352697b6ace7a098ce59b791ab65fc6714 /meta-ibm/meta-fsp2
parent897b7444e5ee1ce045b536aa822f20a95c5dd63d (diff)
downloadopenbmc-bb99d22ecef61f3af21290b1e1ead3083f25d20f.tar.xz
treewide: fix up github SRC_URIs
Per [1], Yocto is going to start requiring both branch names and `protocol=https` in GitHub SRC_URI variables. Ran the upstream tool to automatically fix our URIs. 1. https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n10 Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I5f9619f7ff707050b469ae74c8aa16846568c5e4
Diffstat (limited to 'meta-ibm/meta-fsp2')
-rw-r--r--meta-ibm/meta-fsp2/recipes-bsp/u-boot/u-boot-fsp2_git.bb2
-rw-r--r--meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-ibm/meta-fsp2/recipes-bsp/u-boot/u-boot-fsp2_git.bb b/meta-ibm/meta-fsp2/recipes-bsp/u-boot/u-boot-fsp2_git.bb
index 941f8b4ddf..aae0c09d6e 100644
--- a/meta-ibm/meta-fsp2/recipes-bsp/u-boot/u-boot-fsp2_git.bb
+++ b/meta-ibm/meta-fsp2/recipes-bsp/u-boot/u-boot-fsp2_git.bb
@@ -1,6 +1,6 @@
require recipes-bsp/u-boot/u-boot.inc
-SRC_URI = "git://github.com/openbmc/u-boot;branch=v2017.11-fsp2-openbmc"
+SRC_URI = "git://github.com/openbmc/u-boot;branch=v2017.11-fsp2-openbmc;protocol=https"
SRCREV = "d675f0a16ecc876b1aa78b4151af89c80fe0f4b9"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
diff --git a/meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc b/meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc
index 8a853c3572..9419494763 100644
--- a/meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc
+++ b/meta-ibm/meta-fsp2/recipes-kernel/linux/linux-fsp2.inc
@@ -4,7 +4,7 @@ LICENSE = "GPLv2"
KCONFIG_MODE="--alldefconfig"
-KSRC ?= "git://github.com/openbmc/linux;protocol=git;branch=dev-4.17"
+KSRC ?= "git://github.com/openbmc/linux;protocol=https;branch=dev-4.17"
SRC_URI = "${KSRC}"
LINUX_VERSION_EXTENSION ?= "-${SRCREV}"