summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-genesis3/recipes-phosphor
diff options
context:
space:
mode:
authorPatrick Rudolph <patrick.rudolph@9elements.com>2023-05-03 18:49:46 +0300
committerPatrick Rudolph <patrick.rudolph@9elements.com>2023-11-06 12:33:22 +0300
commit2073a57b8c90869a7a8f1a7c4e7278ad3048bed1 (patch)
tree42c6cf64ebd8d9db9edd17ffe19d79bdec7ef390 /meta-ibm/meta-genesis3/recipes-phosphor
parent9fd0403bb04b24e0836fb5e601c6deecccd8dbcb (diff)
downloadopenbmc-2073a57b8c90869a7a8f1a7c4e7278ad3048bed1.tar.xz
meta-ibm: genesis3: Add entity-manager config
- Add blacklist for I2C buses that have no FRU devices. - Default to dbus-sensors. Tested: All configured sensors are visible in the webui. Change-Id: Ia08f473775eac836e01ab7cc9a7e0eaf56d99192 Signed-off-by: Patrick Rudolph <patrick.rudolph@9elements.com>
Diffstat (limited to 'meta-ibm/meta-genesis3/recipes-phosphor')
-rw-r--r--meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager/blacklist.json3
-rw-r--r--meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager_%.bbappend7
2 files changed, 10 insertions, 0 deletions
diff --git a/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager/blacklist.json b/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager/blacklist.json
new file mode 100644
index 0000000000..3ef400f0ae
--- /dev/null
+++ b/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager/blacklist.json
@@ -0,0 +1,3 @@
+{
+ "buses": [0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86, 87, 88, 89, 90, 91, 92, 93, 94, 95, 96, 97, 98, 99, 100, 101, 102, 103, 104, 105, 106, 107, 108, 109, 110, 111, 112, 113, 114, 115, 116, 117, 118, 119, 120, 121, 122, 123, 124, 125, 126, 127, 128, 129, 130, 131, 132, 133, 134, 135, 136, 137, 138, 139, 140, 141, 142, 143, 144, 145, 146, 147, 148, 149, 166, 167, 168, 169, 170, 171, 172, 173, 174, 175, 176, 177, 178, 179, 180, 181, 182, 183, 184, 185, 186, 187, 188, 189, 190, 191, 192, 193, 194, 195, 196, 197, 198, 199, 200, 201, 202, 203, 204]
+}
diff --git a/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager_%.bbappend
new file mode 100644
index 0000000000..62e1499410
--- /dev/null
+++ b/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append = " file://blacklist.json"
+
+do_install:append () {
+ install -m 0644 -D ${WORKDIR}/blacklist.json ${D}${datadir}/${PN}/blacklist.json
+}