summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-palmetto/recipes-phosphor
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2020-01-16 10:18:09 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-17 21:24:14 +0300
commit1da9757e5dfdebd14c870c40a3d1a7f9ab5ede87 (patch)
tree814756753a520cdcc71c5735983d1069dfdc422b /meta-ibm/meta-palmetto/recipes-phosphor
parent77b79467082d25cba946736f568b93072ecf4822 (diff)
downloadopenbmc-1da9757e5dfdebd14c870c40a3d1a7f9ab5ede87.tar.xz
meta-palmetto: Fix issues found by HW CI
HW CI on Palmetto trigers two issues: 1. The case to verify occ active fails because it was using the last character of `cpux` for occ, e.g. cpu0 -> occ0. Palmetto had an incorrect inventory path of `cpu`, which results in `occu`, and it becomes an incorrect path, and the case gets a 404 error while trying to get the OCC active state. 2. The case to get https://$bmc/ fails, it's expecting HTTP 200 OK resonse, but got a 401 error. This is because webui is not built into Palmetto, so there is no page, and bmcweb returns 401 for such case. Fix the above cases. Tested: Verify the HW CI succeeds on Palmetto: python3 -m robot -v OPENBMC_HOST:palmetto --argumentfile \ test_lists/HW_CI --exclude Verify_Redfish_Host_PowerOn --include \ Verify_Redfish_Host_PowerOn_No_Check_Watts redfish tests (From meta-ibm rev: 4ac52cb28db30f89bdfd23ab1614f71b65dfdceb) Signed-off-by: Lei YU <mine260309@gmail.com> Change-Id: Ifd102f167cfa4d83769fb055b883e4c214a27b9a Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-palmetto/recipes-phosphor')
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/configuration/palmetto-yaml-config/palmetto-ipmi-sensors.yaml2
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/configuration/palmetto-yaml-config/palmetto-ipmi-sensors.yaml b/meta-ibm/meta-palmetto/recipes-phosphor/configuration/palmetto-yaml-config/palmetto-ipmi-sensors.yaml
index 372ad2dbbd..349b8b988a 100644
--- a/meta-ibm/meta-palmetto/recipes-phosphor/configuration/palmetto-yaml-config/palmetto-ipmi-sensors.yaml
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/configuration/palmetto-yaml-config/palmetto-ipmi-sensors.yaml
@@ -584,7 +584,7 @@
deassert: false
type: bool
mutability: Mutability::Write|Mutability::Read
- path: /system/chassis/motherboard/cpu
+ path: /system/chassis/motherboard/cpu0
readingType: assertion
sensorNamePattern: nameLeaf
sensorReadingType: 111
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index c0748b966e..52b9468ccb 100644
--- a/meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1 +1 @@
-RDEPENDS_${PN}-inventory_append_palmetto = " openpower-occ-control"
+RDEPENDS_${PN}-inventory_append_palmetto = " openpower-occ-control phosphor-webui"