summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-romulus/recipes-phosphor/chassis
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:17:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-02 16:19:25 +0300
commite83c22094b7e4970c96bcee273ab08d05bbc0a30 (patch)
tree80cb87a34afb07b7d375b534bb5df68468c2b5a6 /meta-ibm/meta-romulus/recipes-phosphor/chassis
parentd97cf9b9ef84cdad2f357164e36b76619e7dc379 (diff)
downloadopenbmc-e83c22094b7e4970c96bcee273ab08d05bbc0a30.tar.xz
meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override syntax, including the SYSTEMD_ variables. Change our systemd.bbclass to do the same for consistency and perform a tree-wide variable replacement. Spot checked by building bletchley and witherspoon and checking some of the SYSTEMD_LINK directives on installed packages under qemu. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
Diffstat (limited to 'meta-ibm/meta-romulus/recipes-phosphor/chassis')
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb4
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
index 52fc793acd..36b77a03d8 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
@@ -28,6 +28,6 @@ FMT_EN = "../${TMPL_EN}:${TGTFMT}.requires/${INSTFMT_EN}"
FMT_DIS = "../${TMPL_DIS}:${TGTFMT}.requires/${INSTFMT_DIS}"
SYSTEMD_SERVICE:${PN} += "${TMPL_EN}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_EN', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_EN', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_SERVICE:${PN} += "${TMPL_DIS}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_DIS', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_DIS', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
index 7981baa0c0..f25f354421 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
@@ -24,4 +24,4 @@ TGTFMT = "obmc-chassis-poweron@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
SYSTEMD_SERVICE:${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"