summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-system1
diff options
context:
space:
mode:
authorAsmitha Karunanithi <asmitk01@in.ibm.com>2024-08-01 15:40:34 +0300
committerAsmitha Karunanithi <asmitk01@in.ibm.com>2024-09-04 07:39:35 +0300
commite8b9df1db946cccfa16b93bd00dadff613243784 (patch)
tree4397f0e061f96c41ea05bcd0a4e1f675056f055e /meta-ibm/meta-system1
parent4b996a462466c46bee934f488f96f7e045b703a9 (diff)
downloadopenbmc-e8b9df1db946cccfa16b93bd00dadff613243784.tar.xz
meta-ibm: Add SMBIOS support in meta-system1
This commit pulls: 1. smbios-mdr recipe that is responsible for parsing the smbios table sent down by the host, and publishes the system information on the dbus objects. 2. phosphor-ipmi-blobs: this is an alternative implementation of IPMI blob transfer API. The blob handler writes the data into `/var/lib/smbios/smbios2` path (the local persistent cache for the SMBIOS table) and triggers smbios-mdr to reload and parse the table from that file. Tested By: Verified that the smbios data is transferred via IPMI to the BMC and the smbios-mdr service reads that data and populates the dbus object. Change-Id: I7eb54695c46cd8d0392b8ce7c942fedeb56b5d14 Signed-off-by: Asmitha Karunanithi <asmitk01@in.ibm.com>
Diffstat (limited to 'meta-ibm/meta-system1')
-rw-r--r--meta-ibm/meta-system1/conf/machine/system1.conf2
-rw-r--r--meta-ibm/meta-system1/recipes-phosphor/images/obmc-phosphor-image.bbappend1
-rw-r--r--meta-ibm/meta-system1/recipes-phosphor/smbios/smbios-mdr_git.bbappend1
3 files changed, 4 insertions, 0 deletions
diff --git a/meta-ibm/meta-system1/conf/machine/system1.conf b/meta-ibm/meta-system1/conf/machine/system1.conf
index 922e04c79e..c759f367ec 100644
--- a/meta-ibm/meta-system1/conf/machine/system1.conf
+++ b/meta-ibm/meta-system1/conf/machine/system1.conf
@@ -13,7 +13,9 @@ include conf/distro/include/extra-dev-debug-tools.inc
MACHINE_FEATURES += "\
obmc-phosphor-chassis-mgmt \
+ obmc-host-ipmi \
"
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
VIRTUAL-RUNTIME_obmc-sensors-hwmon = "dbus-sensors"
diff --git a/meta-ibm/meta-system1/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-ibm/meta-system1/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 14fde27c60..15ef8726c7 100644
--- a/meta-ibm/meta-system1/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-ibm/meta-system1/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -2,3 +2,4 @@
IMAGE_FEATURES:remove = " \
obmc-leds \
"
+OBMC_IMAGE_EXTRA_INSTALL:append:system1 = " phosphor-ipmi-blobs smbios-mdr"
diff --git a/meta-ibm/meta-system1/recipes-phosphor/smbios/smbios-mdr_git.bbappend b/meta-ibm/meta-system1/recipes-phosphor/smbios/smbios-mdr_git.bbappend
new file mode 100644
index 0000000000..bafc873cb7
--- /dev/null
+++ b/meta-ibm/meta-system1/recipes-phosphor/smbios/smbios-mdr_git.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG:append = " smbios-ipmi-blob"