summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-bsp
diff options
context:
space:
mode:
authorEddie James <eajames@linux.ibm.com>2022-05-27 00:47:33 +0300
committerAndrew Geissler <andrew@geissonator.com>2022-11-29 05:10:41 +0300
commitb8b4f0c36036d2dd0db233f223545366a5e60eb3 (patch)
treeb20deb77203b7418decd851ae3b4e27a263b7c51 /meta-ibm/recipes-bsp
parent3bdd8ebd4409039bde4b2de7bfa7b98c3ed12742 (diff)
downloadopenbmc-b8b4f0c36036d2dd0db233f223545366a5e60eb3.tar.xz
meta-ibm: p10bmc: Add machine U-Boot configuration fragment
Configure U-Boot for p10bmc machines to enable the "AST2600 IBM" board and disable conflicting options. Follow the pattern used by the Qualcomm layer of putting the snippet in files, which has the added bonus of saving a level of directory nesting. Signed-off-by: Eddie James <eajames@linux.ibm.com> Change-Id: I30a2822b65c5ff826f9f5b3fa71bcec9d402c74c
Diffstat (limited to 'meta-ibm/recipes-bsp')
-rw-r--r--meta-ibm/recipes-bsp/u-boot/files/p10bmc.cfg2
-rw-r--r--meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend2
2 files changed, 4 insertions, 0 deletions
diff --git a/meta-ibm/recipes-bsp/u-boot/files/p10bmc.cfg b/meta-ibm/recipes-bsp/u-boot/files/p10bmc.cfg
new file mode 100644
index 0000000000..fdff71d7f4
--- /dev/null
+++ b/meta-ibm/recipes-bsp/u-boot/files/p10bmc.cfg
@@ -0,0 +1,2 @@
+CONFIG_BOARD_EARLY_INIT_F=n
+CONFIG_TARGET_AST2600_IBM=y
diff --git a/meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend b/meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend
index b8055878e3..b752dd5a62 100644
--- a/meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend
+++ b/meta-ibm/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bbappend
@@ -1,6 +1,8 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI:append:p10bmc = " file://ibm.json file://ips.json file://keys/"
+SRC_URI:append:p10bmc = " file://p10bmc.cfg"
OTPTOOL_CONFIGS:p10bmc = "${WORKDIR}/ibm.json ${WORKDIR}/ips.json"
OTPTOOL_KEY_DIR:p10bmc = "${WORKDIR}/keys/"