summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2020-05-12 22:08:30 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-27 00:33:33 +0300
commitc358bce9b48a07b86133b443ad07f17d72ddfd6e (patch)
tree261df904b5ff9f3602211d0aad8fb109d9db4a00 /meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
parentda4c5d402e510b08dca8353281bc17f90fec679d (diff)
downloadopenbmc-c358bce9b48a07b86133b443ad07f17d72ddfd6e.tar.xz
witherspoon: Remove `witherspoon` naming from fan watchdog
Remove the use of `witherspoon` in the names of the recipe, config files, and services of the fan watchdog. This is in prep to use this same fan watchdog on other machines within meta-ibm that have different configurations. Tested: Witherspoon image matches image prior to change Flash image to Witherspoon and force watchdog to trip (From meta-ibm rev: 80f819efec08f7cc7de6988f64c0c77e20990f05) Change-Id: I77295974397cd4903cd1a723b9ef97ee744d2557 Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/fans/fan-watchdog.bb')
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb b/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
new file mode 100644
index 0000000000..d71b378cfb
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Fan watchdog services"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit obmc-phosphor-systemd
+
+RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS_${PN} += "busybox"
+
+RESET_SERVICE = "reset-fan-watchdog.service"
+TGTFMT = "obmc-chassis-poweron@0.target"
+RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}"
+
+MONITOR_SERVICE = "fan-watchdog-monitor@.service"
+
+WATCHDOG_SERVICE = "fan-watchdog.service"
+WATCHDOG_FMT = "../${WATCHDOG_SERVICE}:${TGTFMT}.requires/${WATCHDOG_SERVICE}"
+
+SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE} ${WATCHDOG_SERVICE}"
+SYSTEMD_LINK_${PN} += "${RESET_FMT} ${WATCHDOG_FMT}"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/reset-fan-watchdog.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/fan-watchdog.conf"