summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2021-08-19 18:45:32 +0300
committerMatthew Barth <msbarth@linux.ibm.com>2021-09-13 18:39:16 +0300
commit810504de6665d0c48040787c7bbd52d1c90ee0cc (patch)
tree4c470d6a7a1017077161b0aa090529ac0d0c4dab /meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
parentf90670136a3fe051b8b8e09215f790cac3c110ee (diff)
downloadopenbmc-810504de6665d0c48040787c7bbd52d1c90ee0cc.tar.xz
meta-ibm:fans:monitor: Use JSON config files installed from repo
The `witherspoon` and `p10bmc` machines' JSON config files should now use the JSON config files installed from the repository. Change-Id: I47669745aa7047c4de64ee8aedc98437593a3b62 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend')
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
deleted file mode 100644
index 85cc4d82e9..0000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
+++ /dev/null
@@ -1,36 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI:witherspoon = "file://config.json"
-SRC_URI:p10bmc = "file://rainier-2u/config.json \
- file://rainier-4u/config.json \
- file://rainier-1s4u/config.json \
- file://everest/config.json \
- "
-
-do_install:witherspoon() {
- install -d ${D}/${datadir}/phosphor-fan-presence/monitor/
- install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/
-}
-
-do_install:p10bmc() {
- # Install Rainier-2U/4U fan monitor config files
- install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/
- install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/
- install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/
- install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/
- install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/
- install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/
-
- # Install Everest fan monitor config file
- install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/
- install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/
-}
-
-FILES:${PN}:append:witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json"
-FILES:${PN}:remove:witherspoon = "${monitor_datadir}/monitor.yaml"
-
-FILES:${PN}:remove:p10bmc = "${monitor_datadir}/monitor.yaml"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/config.json"
-FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,everest/config.json"