summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/network
diff options
context:
space:
mode:
authorIsha Sahni <isha.sahni1@ibm.com>2023-04-20 12:41:33 +0300
committerisha.sahni1 <isha.sahni1@ibm.com>2023-05-02 11:56:37 +0300
commit7c656216ab3d19e6090bf60ac259dfc99ec85657 (patch)
tree419d2db9242f82c3a49f7dbdf4e41f5527a26fa3 /meta-ibm/recipes-phosphor/network
parent294ec5d37847797737e154614705d08f6850e279 (diff)
downloadopenbmc-7c656216ab3d19e6090bf60ac259dfc99ec85657.tar.xz
meta-ibm: enable persist-mac flag
-mac address wasn't persisting after reboot Tested by: 1. Assign a valid MAC address aa:e2:84:14:28:79 to the system using curl -k -H "X-Auth-Token:${bmc_token}" -X PATCH -D patch.txt -d '{"MACAddress":"AA:E2:84:14:28:79"}' https://$bmc/redfish/v1/Managers/bmc/EthernetInterfaces/eth0 2. Now GET and verify if the MAC address has changed using curl -k -H "X-Auth-Token:${bmc_token}" -X GET https://${bmc}/redfish/v1/Managers/bmc/EthernetInterfaces/eth0 3. Now reboot the BMC and verify if the MAC address remains the same Change-Id: I334f1936f433e3e7e30ca5e669a89112f9879276 Signed-off-by: Isha Sahni <isha.sahni1@ibm.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/network')
-rw-r--r--meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend
index eac0503aee..2cca900780 100644
--- a/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend
+++ b/meta-ibm/recipes-phosphor/network/phosphor-network_%.bbappend
@@ -31,6 +31,7 @@ FILES:${PN} += "${libexecdir}/ncsi-wait-and-set-speed"
FILES:${PN} += "${datadir}/network/*.json"
PACKAGECONFIG:append = " sync-mac"
+PACKAGECONFIG:append = " persist-mac"
PACKAGECONFIG:append:p10bmc = " hyp-nw-config"
install_network_configuration(){