summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/packagegroups
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2022-02-19 05:04:54 +0300
committerAndrew Jeffery <andrew@aj.id.au>2022-02-23 05:07:18 +0300
commit14d942bd35c9d5c2b3cd0ef12a038aaf0a7f3ed7 (patch)
tree26375a89dd030e2f7d0c8e702518fb7623cfd1ca /meta-ibm/recipes-phosphor/packagegroups
parent2407a2b2bc06d0d919de54356854d717aa4a7501 (diff)
downloadopenbmc-14d942bd35c9d5c2b3cd0ef12a038aaf0a7f3ed7.tar.xz
meta-ibm: p10bmc: Add opkg to RDEPENDS:${PN}-extras
Providing `opkg` in the image allows us to easily install packages after-the-fact, usually to debug systems in the lab. This is not a mechanism for providing firmware updates. No specific configuration is supplied to enable its use, and hosting of package archives is left as an exercise to the user. That said, bitbake generates its own package archive in the course of creating the output image. It also provides a `package-index` target, which after execution, allows you to expose the archive with no more work than: ``` $ python3 -m http.server --directory tmp/deploy/ipk 8080` ``` The addition of opkg with the chosen options increases the uncompressed filesystem size by 3855360 bytes (~3.68MiB). Change-Id: I7731a4ebe08249e2216e8ca1984f8e8d87558687 Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Diffstat (limited to 'meta-ibm/recipes-phosphor/packagegroups')
-rw-r--r--meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 42f56cbc54..f39ca6be4e 100644
--- a/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -32,7 +32,7 @@ RDEPENDS:${PN}-fan-control:append:p10bmc = " fan-watchdog sensor-monitor"
RDEPENDS:${PN}-extras:append:ibm-ac-server = " ${POWER_SERVICE_PACKAGES_AC_SERVER} witherspoon-power-supply-sync"
RDEPENDS:${PN}-extras:append:p10bmc = " ${POWER_SERVICE_PACKAGES_P10} webui-vue dbus-sensors phosphor-virtual-sensor"
RDEPENDS:${PN}-extras:append:p10bmc = " pldm openpower-hw-diags srvcfg-manager biosconfig-manager phosphor-post-code-manager phosphor-host-postd debug-trigger libmctp"
-RDEPENDS:${PN}-extras:append:p10bmc = " gdbserver strace"
+RDEPENDS:${PN}-extras:append:p10bmc = " gdbserver strace opkg"
RDEPENDS:${PN}-extras:append:mihawk = " phosphor-webui phosphor-image-signing wistron-ipmi-oem ${POWER_SERVICE_PACKAGES_AC_SERVER}"
RDEPENDS:${PN}-extras:append:witherspoon-tacoma = " pldm srvcfg-manager webui-vue biosconfig-manager phosphor-post-code-manager phosphor-host-postd kexec-tools makedumpfile kdump vmcore-dmesg debug-trigger"