summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/settings
diff options
context:
space:
mode:
authorSunitha Harish <sunithaharish04@gmail.com>2020-01-21 14:08:44 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-08 02:40:35 +0300
commit4909eea10c4bd4ef19a940d81a48351a236ac1c3 (patch)
treee6d349ea55d754606aa4777cee7fba17b5431fe1 /meta-ibm/recipes-phosphor/settings
parentc978da3dbd1f7d7047be9ad9bee3f0df377932d0 (diff)
downloadopenbmc-4909eea10c4bd4ef19a940d81a48351a236ac1c3.tar.xz
Add Hypervisor Virtual Management D-Bus interface objects
This commit adds a new yaml file for holding the Hypervisor's Virtual Management Interface's network objects. This models two ethernet interfaces to the hypervisor and its static IPv4 attributes. Tested by: busctl tree xyz.openbmc_project.Settings (From meta-ibm rev: ae4ab28128052a57f8ddd4c910e27e04f92305d6) Signed-off-by: Sunitha Harish <sunithaharish04@gmail.com> Change-Id: I9a32d943867d26fbf215f248ab944e6f8750f415 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/settings')
-rw-r--r--meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-rainier.override.yml58
-rw-r--r--meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-tacoma.override.yml34
-rw-r--r--meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend2
3 files changed, 94 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-rainier.override.yml b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-rainier.override.yml
new file mode 100644
index 0000000000..fea34cc89e
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-rainier.override.yml
@@ -0,0 +1,58 @@
+/xyz/openbmc_project/network/hypervisor:
+ - Interface: xyz.openbmc_project.Network.SystemConfiguration
+ Properties:
+ HostName:
+ Default: '""'
+ DefaultGateway:
+ Default: '"0.0.0.0"'
+
+/xyz/openbmc_project/network/hypervisor/eth0:
+ - Interface: xyz.openbmc_project.Network.MACAddress
+ Properties:
+ MACAddress:
+ Default: '"00:00:00:00:00:00"'
+ Validation:
+ Type: "regex"
+ Validator: '^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$'
+
+/xyz/openbmc_project/network/hypervisor/eth0/ipv4/addr0:
+ - Interface: xyz.openbmc_project.Network.IP
+ Properties:
+ Address:
+ Default: '"0.0.0.0"'
+ PrefixLength:
+ Default: 0
+ Validation:
+ Type: "range"
+ Validator: 0..32
+ Unit: "bits"
+ Origin:
+ Default: IP::AddressOrigin::Static
+ Type:
+ Default: IP::Protocol::IPv4
+
+/xyz/openbmc_project/network/hypervisor/eth1:
+ - Interface: xyz.openbmc_project.Network.MACAddress
+ Properties:
+ MACAddress:
+ Default: '"00:00:00:00:00:00"'
+ Validation:
+ Type: "regex"
+ Validator: '^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$'
+
+/xyz/openbmc_project/network/hypervisor/eth1/ipv4/addr0:
+ - Interface: xyz.openbmc_project.Network.IP
+ Properties:
+ Address:
+ Default: '"0.0.0.0"'
+ PrefixLength:
+ Default: 0
+ Validation:
+ Type: "range"
+ Validator: 0..32
+ Unit: "bits"
+ Origin:
+ Default: IP::AddressOrigin::Static
+ Type:
+ Default: IP::Protocol::IPv4
+
diff --git a/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-tacoma.override.yml b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-tacoma.override.yml
new file mode 100644
index 0000000000..9e626a606d
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-tacoma.override.yml
@@ -0,0 +1,34 @@
+/xyz/openbmc_project/network/hypervisor:
+ - Interface: xyz.openbmc_project.Network.SystemConfiguration
+ Properties:
+ HostName:
+ Default: '""'
+ DefaultGateway:
+ Default: '"0.0.0.0"'
+
+/xyz/openbmc_project/network/hypervisor/eth0:
+ - Interface: xyz.openbmc_project.Network.MACAddress
+ Properties:
+ MACAddress:
+ Default: '"00:00:00:00:00:00"'
+ Validation:
+ Type: "regex"
+ Validator: '^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$'
+
+/xyz/openbmc_project/network/hypervisor/eth0/ipv4/addr0:
+ - Interface: xyz.openbmc_project.Network.IP
+ Properties:
+ Address:
+ Default: '"0.0.0.0"'
+ PrefixLength:
+ Default: 0
+ Validation:
+ Type: "range"
+ Validator: 0..32
+ Unit: "bits"
+ Origin:
+ Default: IP::AddressOrigin::Static
+ Type:
+ Default: IP::Protocol::IPv4
+
+
diff --git a/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
index 1068e1d003..db95cdad79 100644
--- a/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
@@ -3,3 +3,5 @@ SRC_URI_append_ibm-ac-server = " file://TPMEnable-default-true.override.yml"
SRC_URI_append_ibm-ac-server += " file://ClearHostSecurityKeys-default-zero.override.yml"
SRC_URI_append_mihawk = " file://TPMEnable-default-true.override.yml"
SRC_URI_append = " file://ibm_settings.override.yml"
+SRC_URI_append_rainier = " file://HypervisorInterface-default-rainier.override.yml"
+SRC_URI_append_witherspoon-tacoma = " file://HypervisorInterface-default-tacoma.override.yml"