summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2023-10-16 19:34:23 +0300
committerAndrew Geissler <geissonator@yahoo.com>2023-10-19 21:50:10 +0300
commit58cf919189dc2b70cc0f7373ea07d8005f0699a3 (patch)
tree765a43b6162db7c279a0711dcf1589b099c25ae6 /meta-ibm/recipes-phosphor
parentae4f95cac94c90fd98cd90e24aaf17fc6f8944d4 (diff)
downloadopenbmc-58cf919189dc2b70cc0f7373ea07d8005f0699a3.tar.xz
meta-ibm: system1: add in network IPMI support
System1 requires out of band IPMI management so configure some defaults for it. Tested: - Confirmed ipmitool could communicate with system1 out of band with "chassis power status" command Change-Id: Ie52a08ac4861ada682984a5ae695d82d9bb1c31e Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor')
-rw-r--r--meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-config/system1/channel_config.json178
-rw-r--r--meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-config/system1/dev_id.json2
-rw-r--r--meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend5
3 files changed, 185 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-config/system1/channel_config.json b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-config/system1/channel_config.json
new file mode 100644
index 0000000000..59f1eb98e4
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-config/system1/channel_config.json
@@ -0,0 +1,178 @@
+{
+ "0" : {
+ "name" : "IPMB",
+ "is_valid" : true,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "ipmb",
+ "protocol_type" : "ipmb-1.0",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "1" : {
+ "name" : "eth0",
+ "is_valid" : true,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "lan-802.3",
+ "protocol_type" : "ipmb-1.0",
+ "session_supported" : "multi-session",
+ "is_ipmi" : true
+ }
+ },
+ "2" : {
+ "name" : "eth1",
+ "is_valid" : true,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "lan-802.3",
+ "protocol_type" : "ipmb-1.0",
+ "session_supported" : "multi-session",
+ "is_ipmi" : true
+ }
+ },
+ "3" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "4" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "5" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "6" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "7" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "8" : {
+ "name" : "INTRABMC",
+ "is_valid" : true,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "oem",
+ "protocol_type" : "oem",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "9" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "10" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "11" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "12" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "13" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "14" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ },
+ "15" : {
+ "name" : "RESERVED",
+ "is_valid" : false,
+ "active_sessions" : 0,
+ "channel_info" : {
+ "medium_type" : "reserved",
+ "protocol_type" : "na",
+ "session_supported" : "session-less",
+ "is_ipmi" : true
+ }
+ }
+}
diff --git a/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-config/system1/dev_id.json b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-config/system1/dev_id.json
new file mode 100644
index 0000000000..6cd9a94b30
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-config/system1/dev_id.json
@@ -0,0 +1,2 @@
+{"id": 0, "revision": 128, "addn_dev_support": 141,
+ "manuf_id": 42817, "prod_id": 16975, "aux": 0}
diff --git a/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
index 78807717dc..e7973c8992 100644
--- a/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
+++ b/meta-ibm/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
@@ -5,6 +5,11 @@ SYSTEMD_SERVICE:${PN}:append:p10bmc = " \
${PN}@${ALT_RMCPP_IFACE}.service \
${PN}@${ALT_RMCPP_IFACE}.socket \
"
+ALT_RMCPP_IFACE:system1 = "eth1"
+SYSTEMD_SERVICE:${PN}:append:system1 = " \
+ ${PN}@${ALT_RMCPP_IFACE}.service \
+ ${PN}@${ALT_RMCPP_IFACE}.socket \
+ "
FILESEXTRAPATHS:prepend:p10bmc := "${THISDIR}/${PN}:"
SRC_URI:append:p10bmc = " file://first-boot-disable-ipmi-net.service"