summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor
diff options
context:
space:
mode:
authorNodeMan97 <corey.hardesty@icloud.com>2022-08-02 02:18:57 +0300
committerAdriana Kobylak <anoo@linux.ibm.com>2022-08-31 23:03:29 +0300
commitac37d615e7d3e9ea973f5e3d60e677678d5c28ac (patch)
tree9524d53c294adfa581551afcfb77739a36b57ecf /meta-ibm/recipes-phosphor
parent4bee6dab5e6aebfa4fea77b5c55e3497c6c44e0f (diff)
downloadopenbmc-ac37d615e7d3e9ea973f5e3d60e677678d5c28ac.tar.xz
meta-ibm: monitor /tmp and /var in health monitor
IBM systems utilize /tmp and /var for a variety of purposes so setup the health monitor to look at the remaining space in these file systems. No action at this time other then a log in the journal to provide a clue when looking at an issue. Tested: - Filled up /tmp and verified this log: “Aug 19 19:59:43 p10bmc health-monitor[326]: ASSERT: sensor Storage_TMP is above the upper threshold critical high” - Removed big file from /tmp and verified this log: "Aug 19 20:01:34 p10bmc health-monitor[326]: DEASSERT: sensor Storage_TMP is under the upper threshold critical high” Signed-off-by: NodeMan97 <corey.hardesty@icloud.com> Change-Id: I8a7921dffa6b756a4ab19a0e807e558ccd35f996 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor')
-rw-r--r--meta-ibm/recipes-phosphor/health/files/bmc_health_config.json63
-rw-r--r--meta-ibm/recipes-phosphor/health/phosphor-health-monitor_%.bbappend8
2 files changed, 71 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/health/files/bmc_health_config.json b/meta-ibm/recipes-phosphor/health/files/bmc_health_config.json
new file mode 100644
index 0000000000..39d84842b1
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/health/files/bmc_health_config.json
@@ -0,0 +1,63 @@
+{
+ "CPU" : {
+ "Frequency" : 1,
+ "Window_size": 120,
+ "Threshold":
+ {
+ "Critical":
+ {
+ "Value": 90.0,
+ "Log": true,
+ "Target": ""
+ },
+ "Warning":
+ {
+ "Value": 80.0,
+ "Log": false,
+ "Target": ""
+ }
+ }
+ },
+ "Memory" : {
+ "Frequency" : 1,
+ "Window_size": 120,
+ "Threshold":
+ {
+ "Critical":
+ {
+ "Value": 85.0,
+ "Log": true,
+ "Target": ""
+ }
+ }
+ },
+ "Storage_VAR" : {
+ "Path" : "/var",
+ "Frequency" : 1,
+ "Window_size": 120,
+ "Threshold":
+ {
+ "Critical":
+ {
+ "Value": 85.0,
+ "Log": true,
+ "Target": ""
+ }
+ }
+ },
+ "Storage_TMP" : {
+ "Path" : "/tmp",
+ "Frequency" : 1,
+ "Window_size":120,
+ "Threshold":
+ {
+ "Critical":
+ {
+ "Value": 85.0,
+ "Log": true,
+ "Target": ""
+ }
+ }
+ }
+}
+
diff --git a/meta-ibm/recipes-phosphor/health/phosphor-health-monitor_%.bbappend b/meta-ibm/recipes-phosphor/health/phosphor-health-monitor_%.bbappend
new file mode 100644
index 0000000000..3bd38170da
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/health/phosphor-health-monitor_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+SRC_URI:append = " file://bmc_health_config.json \
+ "
+do_install:append() {
+ install -d ${D}/${sysconfdir}/healthMon/
+ install -m 0644 ${WORKDIR}/bmc_health_config.json ${D}/${sysconfdir}/healthMon/
+}
+