summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2019-04-12 21:20:39 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-26 16:38:58 +0300
commit79b6cb1267b0c4637c2385790e52025de48e04fa (patch)
treedd7167e985e345e47864e8ecfb6f0417ef181433 /meta-ibm
parent0c03a862f259958157b99b4912046499b8991f7c (diff)
downloadopenbmc-79b6cb1267b0c4637c2385790e52025de48e04fa.tar.xz
wspoon: Use machine in file path append for fans
In preparation for additional systems under the witherspoon layer, add the machine name as a prefix to the phosphor-fan* configuration directories. This allows additional machines' phosphor-fan* configurations to be placed in this layer. Tested: Witherspoon phosphor-fan image still contains applications & phosphor-fan applications are correctly configured. (From meta-ibm rev: a63359eebc376e3340bdbc34fc4c83410172a5ae) Change-Id: I9d711cb68e4563e5a2c6dc88d12d2071364bf8ae Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-events-config-native/events.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-events-config-native/events.yaml)0
-rwxr-xr-xmeta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-fan-config-native/fans.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-fan-config-native/fans.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-zone-config-native/zones.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-config-native/zones.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-monitor-config-native/monitor.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-monitor-config-native/monitor.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-presence-config-native/config.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config-native/config.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan/phosphor-cooling-type@.service (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service)0
15 files changed, 8 insertions, 7 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend
index 72d991c7e5..fae8d4c5dc 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend
index 72d991c7e5..fae8d4c5dc 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend
index 72d991c7e5..fae8d4c5dc 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend
index 6d4804d127..fae8d4c5dc 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend
@@ -1,2 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
+FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend
index 72d991c7e5..fae8d4c5dc 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend
index 72d991c7e5..fae8d4c5dc 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
index f2878fb771..e28bcb1d04 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,4 +1,6 @@
FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+# Machine specific files override shared files with the same name
+FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
# Package configuration
FAN_PACKAGES += " \
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-events-config-native/events.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-events-config-native/events.yaml
index 5f6a094bac..5f6a094bac 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-events-config-native/events.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-events-config-native/events.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-fan-config-native/fans.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-fan-config-native/fans.yaml
index a70ac85a32..a70ac85a32 100755
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-fan-config-native/fans.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-fan-config-native/fans.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml
index 0c8b3c5ff2..0c8b3c5ff2 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-config-native/zones.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-zone-config-native/zones.yaml
index d31b304450..d31b304450 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-control-zone-config-native/zones.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-control-zone-config-native/zones.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-monitor-config-native/monitor.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-monitor-config-native/monitor.yaml
index 5db7966fa9..5db7966fa9 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-monitor-config-native/monitor.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-monitor-config-native/monitor.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config-native/config.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-presence-config-native/config.yaml
index 1c26fc21f1..1c26fc21f1 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config-native/config.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan-presence-config-native/config.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf
index e5e8f435e0..e5e8f435e0 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan/obmc/phosphor-fan/phosphor-cooling-type-0.conf
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan/phosphor-cooling-type@.service
index c1f5ae2932..c1f5ae2932 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan/phosphor-cooling-type@.service
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-phosphor-fan/phosphor-cooling-type@.service