summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorBen_Pai <ben_pai@wistron.com>2019-08-21 13:04:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-12 05:23:01 +0300
commit89e6501fb0445ac501389074d00440a61f60d01c (patch)
treefc1d544ff20440121c41ab4aa26a63686cc71287 /meta-ibm
parent78b4cc4835d51df1d25b307049df5616482819c6 (diff)
downloadopenbmc-89e6501fb0445ac501389074d00440a61f60d01c.tar.xz
meta-ibm: Add mihawk ipmi yaml.
Add mihawk's ipmi sensor and fru yaml. Tested: Use ipmi command to get the sensor list and fru data. (From meta-ibm rev: 05c9a2734de75271837313f0e1794c58df50e990) Signed-off-by: Ben Pai <Ben_Pai@wistron.com> Change-Id: Ic85af9b0cc1b44a3377fa919e63ab04dbff7a31c Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb15
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/mihawk/acx22-ipmi-fru-bmc.yaml102
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/mihawk/acx22-ipmi-hwmon-sensors.yaml483
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend4
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend5
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend6
6 files changed, 612 insertions, 3 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
index d0dbd60d8f..245693ac8f 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd
inherit allarch
inherit mrw-xml
-SRC_URI = " \
+SRC_URI_ibm-ac-server = " \
file://acx22-ipmi-fru-bmc.yaml \
file://acx22-ipmi-fru-not-sent-by-host.yaml \
file://acx22-ipmi-hwmon-sensors.yaml \
@@ -14,7 +14,13 @@ SRC_URI = " \
file://acx22-ipmi-occ-sensors.yaml \
file://acx22-ipmi-sensors-mrw.yaml \
"
-
+SRC_URI_mihawk = " \
+ file://acx22-ipmi-fru-bmc.yaml \
+ file://acx22-ipmi-hwmon-sensors.yaml \
+ file://acx22-ipmi-inventory-sensors.yaml \
+ file://acx22-ipmi-occ-sensors.yaml \
+ file://acx22-ipmi-sensors-mrw.yaml \
+ "
DEPENDS = " \
mrw-native \
mrw-perl-tools-native \
@@ -23,10 +29,13 @@ DEPENDS = " \
S = "${WORKDIR}"
-ACx22_IPMI_EXTRA_FRU_READ_YAMLS = " \
+ACx22_IPMI_EXTRA_FRU_READ_YAMLS_ibm-ac-server = " \
acx22-ipmi-fru-bmc.yaml \
acx22-ipmi-fru-not-sent-by-host.yaml \
"
+ACx22_IPMI_EXTRA_FRU_READ_YAMLS_mihawk = " \
+ acx22-ipmi-fru-bmc.yaml \
+ "
ACx22_IPMI_EXTRA_SENSOR_YAMLS = " \
acx22-ipmi-hwmon-sensors.yaml \
acx22-ipmi-occ-sensors.yaml \
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/mihawk/acx22-ipmi-fru-bmc.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/mihawk/acx22-ipmi-fru-bmc.yaml
new file mode 100644
index 0000000000..57adcaf778
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/mihawk/acx22-ipmi-fru-bmc.yaml
@@ -0,0 +1,102 @@
+50:
+ /system/chassis/motherboard/fan0:
+ entityID: 29
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Product Name
+ IPMIFruSection: Product
+51:
+ /system/chassis/motherboard/fan1:
+ entityID: 29
+ entityInstance: 2
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Product Name
+ IPMIFruSection: Product
+52:
+ /system/chassis/motherboard/fan2:
+ entityID: 29
+ entityInstance: 3
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Product Name
+ IPMIFruSection: Product
+53:
+ /system/chassis/motherboard/fan3:
+ entityID: 29
+ entityInstance: 4
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Product Name
+ IPMIFruSection: Product
+54:
+ /system/chassis/motherboard/fan4:
+ entityID: 29
+ entityInstance: 5
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Product Name
+ IPMIFruSection: Product
+55:
+ /system/chassis/motherboard/fan5:
+ entityID: 29
+ entityInstance: 6
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Product Name
+ IPMIFruSection: Product
+75:
+ /system/chassis/motherboard/powersupply0:
+ entityID: 10
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Board Name
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ Model:
+ IPMIFruProperty: Model Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+76:
+ /system/chassis/motherboard/powersupply1:
+ entityID: 10
+ entityInstance: 2
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Board Name
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ Model:
+ IPMIFruProperty: Model Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/mihawk/acx22-ipmi-hwmon-sensors.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/mihawk/acx22-ipmi-hwmon-sensors.yaml
new file mode 100644
index 0000000000..03b9700dca
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config/mihawk/acx22-ipmi-hwmon-sensors.yaml
@@ -0,0 +1,483 @@
+232:
+ bExp: 0
+ entityID: 29
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan0_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+233:
+ bExp: 0
+ entityID: 29
+ entityInstance: 3
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan1_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+234:
+ bExp: 0
+ entityID: 29
+ entityInstance: 5
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan2_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+235:
+ bExp: 0
+ entityID: 29
+ entityInstance: 7
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan3_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+236:
+ bExp: 0
+ entityID: 29
+ entityInstance: 9
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan4_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+237:
+ bExp: 0
+ entityID: 29
+ entityInstance: 11
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 100
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/fan_tach/fan5_0
+ rExp: 0
+ readingType: readingData
+ scale: 0
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 4
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+238:
+ bExp: 0
+ entityID: 10
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/storage_a_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+239:
+ bExp: 0
+ entityID: 10
+ entityInstance: 2
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/storage_b_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+240:
+ bExp: 0
+ entityID: 10
+ entityInstance: 3
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p0_vdd_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+241:
+ bExp: 0
+ entityID: 10
+ entityInstance: 4
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p1_vdd_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+242:
+ bExp: 0
+ entityID: 10
+ entityInstance: 5
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p0_mem_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+243:
+ bExp: 0
+ entityID: 10
+ entityInstance: 6
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/p1_mem_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+244:
+ bExp: 0
+ entityID: 10
+ entityInstance: 7
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/ps0_input_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+245:
+ bExp: 0
+ entityID: 10
+ entityInstance: 8
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/power/ps1_input_power
+ rExp: 0
+ readingType: readingData
+ scale: -6
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 8
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Watts
+246:
+ bExp: 0
+ entityID: 10
+ entityInstance: 9
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/voltage/ps0_input_voltage
+ rExp: 0
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 2
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+247:
+ bExp: 0
+ entityID: 10
+ entityInstance: 10
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 2
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/voltage/ps1_input_voltage
+ rExp: 0
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 2
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+248:
+ bExp: 0
+ entityID: 10
+ entityInstance: 11
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 10
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/voltage/ps0_output_voltage
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 2
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+249:
+ bExp: 0
+ entityID: 10
+ entityInstance: 12
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 10
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/voltage/ps1_output_voltage
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 2
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+250:
+ bExp: 0
+ entityID: 10
+ entityInstance: 13
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 1
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/current/ps0_output_current
+ rExp: 0
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 3
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Amperes
+251:
+ bExp: 0
+ entityID: 10
+ entityInstance: 14
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 1
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/current/ps1_output_current
+ rExp: 0
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 3
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Amperes
+252:
+ bExp: 0
+ entityID: 35
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 30
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/temperature/p0_pcie_temp
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 1
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+253:
+ bExp: 0
+ entityID: 35
+ entityInstance: 2
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 30
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/temperature/p1_pcie_temp
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 1
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+254:
+ bExp: 0
+ entityID: 64
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 255:
+ type: int64_t
+ multiplierM: 20
+ offsetB: 0
+ path: /xyz/openbmc_project/sensors/temperature/ambient_temp
+ rExp: -2
+ readingType: readingData
+ scale: -3
+ sensorNamePattern: nameLeaf
+ sensorReadingType: 1
+ sensorType: 1
+ serviceInterface: org.freedesktop.DBus.Properties
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
index ae379af3fe..fd27f7dced 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
@@ -1,5 +1,9 @@
DEPENDS_append_ibm-ac-server = " acx22-yaml-config"
+DEPENDS_append_mihawk = " acx22-yaml-config"
EXTRA_OECONF_ibm-ac-server = " \
INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
"
+EXTRA_OECONF_mihawk = " \
+ INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
+ " \ No newline at end of file
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
index 2da9493df8..6efe241bcc 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -1,6 +1,11 @@
DEPENDS_append_ibm-ac-server = " acx22-yaml-config"
+DEPENDS_append_mihawk = " acx22-yaml-config"
EXTRA_OECONF_ibm-ac-server = " \
YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-fru-read.yaml \
PROP_YAML=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-extra-properties.yaml \
"
+EXTRA_OECONF_mihawk = " \
+ YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-fru-read.yaml \
+ PROP_YAML=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-extra-properties.yaml \
+ "
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 3fdcada432..8d51478af9 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,7 +1,13 @@
DEPENDS_append_ibm-ac-server = " acx22-yaml-config"
+DEPENDS_append_mihawk = " acx22-yaml-config"
EXTRA_OECONF_ibm-ac-server = " \
SENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-sensors.yaml \
INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
FRU_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-fru-read.yaml \
"
+EXTRA_OECONF_mihawk = " \
+ SENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-sensors.yaml \
+ INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
+ FRU_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-fru-read.yaml \
+ " \ No newline at end of file