summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-common/recipes-phosphor/dbus
diff options
context:
space:
mode:
authoreportnov <eportnov@ibs.ru>2022-07-08 10:57:50 +0300
committereportnov <eportnov@ibs.ru>2022-07-08 10:59:20 +0300
commitd08a2a08a454b0861f973df7e42b32d78c6ec166 (patch)
tree773d42243872480631e380bfec6961882db89a62 /meta-ibs/meta-common/recipes-phosphor/dbus
parent1837f3865020b2f28f299b4a11ce36b62877734b (diff)
downloadopenbmc-d08a2a08a454b0861f973df7e42b32d78c6ec166.tar.xz
Add new field to bmcwebfeature/add_field_cpu
Diffstat (limited to 'meta-ibs/meta-common/recipes-phosphor/dbus')
-rw-r--r--meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0003-Add-new-fields-to-cpu.patch70
-rw-r--r--meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend1
2 files changed, 71 insertions, 0 deletions
diff --git a/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0003-Add-new-fields-to-cpu.patch b/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0003-Add-new-fields-to-cpu.patch
new file mode 100644
index 0000000000..f10da21652
--- /dev/null
+++ b/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0003-Add-new-fields-to-cpu.patch
@@ -0,0 +1,70 @@
+From 4b2a14e510495ef42d638584a62ab3c9ccf24056 Mon Sep 17 00:00:00 2001
+From: eportnov <eportnov@ibs.ru>
+Date: Thu, 7 Jul 2022 17:52:12 +0300
+Subject: [PATCH] Add new fields to cpu
+
+---
+ .../Inventory/Item/Cpu.interface.yaml | 36 ++++++++++++++++++-
+ 1 file changed, 35 insertions(+), 1 deletion(-)
+
+diff --git a/yaml/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml b/yaml/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml
+index 211673d..174a80e 100644
+--- a/yaml/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml
++++ b/yaml/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml
+@@ -37,6 +37,10 @@ properties:
+ type: uint32
+ description: >
+ Max Speed in megahertz the CPU can support.
++ - name: MinSpeedMHz
++ type: uint32
++ description: >
++ Min Speed in megahertz the CPU can support.
+ - name: Characteristics
+ type: array[enum[self.Capability]]
+ description: >
+@@ -72,6 +76,12 @@ properties:
+ The set of boolean flags for processor's capability, such as
+ 64-bit Capable, Multi-Core, Hardware Thread, Execute Protection,
+ Enhanced Virtualization, Power/Performance Control etc.
++ - name: ProcessorArchitecture
++ type: enum[self.ProcessorArchitecture]
++ description: >
++ The set of boolean flags for processor's capability, such as
++ 64-bit Capable, Multi-Core, Hardware Thread, Execute Protection,
++ Enhanced Virtualization, Power/Performance Control etc.
+
+ enumerations:
+ - name: Capability
+@@ -130,7 +140,31 @@ enumerations:
+ - name: x86_64
+ description: >
+ Support power/performance control.
+-
++
++ - name: ProcessorArchitecture
++ description: >
++ Contain the string that identifies the architecture
++ of the processor contained in this socket
++ values:
++ - name: ARM
++ description: >
++ ARM.
++ - name: IA_64
++ description: >
++ Intel Itanium.
++ - name: MIPS
++ description: >
++ MIPS.
++ - name: OEM
++ description: >
++ OEM-defined.
++ - name: Power
++ description: >
++ Power.
++ - name: x86
++ description: >
++ x86 or x86-64.
++
+ associations:
+ - name: associated_pcie_slots
+ description: >
diff --git a/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend b/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
index 614db6e4d2..34fb790278 100644
--- a/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
+++ b/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
@@ -21,4 +21,5 @@ SRC_URI += "file://0007-ipmi-set-BIOS-id.patch \
file://0034-Add-username-property-to-SessionInfo-interface.patch \
file://0035-Remove-read-only-flag-from-NTPServers.patch \
file://0036-add-fields.patch \
+ file://0003-Add-new-fields-to-cpu.patch \
"