summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-common/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorNikita Kosenkov <NKosenkov@IBS.RU>2022-08-26 23:24:41 +0300
committerNikita Kosenkov <NKosenkov@IBS.RU>2022-08-26 23:24:41 +0300
commite1efe61e2ea1a22fa912cb41975936f11e95c3f2 (patch)
tree95f3e75c7107750b05b6f7502e4d1d994d4fb239 /meta-ibs/meta-common/recipes-phosphor/dbus
parentc33060c6eed995e0e5e2723d68a3c8bbffa0ed90 (diff)
downloadopenbmc-e1efe61e2ea1a22fa912cb41975936f11e95c3f2.tar.xz
phosphor-dbus-interfaces: Change CPU interface according to latest upstream version
Diffstat (limited to 'meta-ibs/meta-common/recipes-phosphor/dbus')
-rw-r--r--meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0039-Change-CPU-interface-according-to-latest-upstream-ve.patch101
-rw-r--r--meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend1
2 files changed, 102 insertions, 0 deletions
diff --git a/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0039-Change-CPU-interface-according-to-latest-upstream-ve.patch b/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0039-Change-CPU-interface-according-to-latest-upstream-ve.patch
new file mode 100644
index 0000000000..17040ba2ed
--- /dev/null
+++ b/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0039-Change-CPU-interface-according-to-latest-upstream-ve.patch
@@ -0,0 +1,101 @@
+From 4f14d21bf0daebb8cd571593cff5c7ea6dac1633 Mon Sep 17 00:00:00 2001
+From: Nikita Kosenkov <NKosenkov@IBS.RU>
+Date: Fri, 26 Aug 2022 23:03:40 +0300
+Subject: [PATCH] Change CPU interface according to latest upstream version
+
+---
+ .../Inventory/Item/Cpu.interface.yaml | 71 +------------------
+ 1 file changed, 1 insertion(+), 70 deletions(-)
+
+diff --git a/yaml/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml b/yaml/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml
+index 174a80e..19f551d 100644
+--- a/yaml/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml
++++ b/yaml/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml
+@@ -70,18 +70,6 @@ properties:
+ description: >
+ Vendor or supplier
+ default: ""
+- - name: InstructionSet
+- type: enum[self.Instruction]
+- description: >
+- The set of boolean flags for processor's capability, such as
+- 64-bit Capable, Multi-Core, Hardware Thread, Execute Protection,
+- Enhanced Virtualization, Power/Performance Control etc.
+- - name: ProcessorArchitecture
+- type: enum[self.ProcessorArchitecture]
+- description: >
+- The set of boolean flags for processor's capability, such as
+- 64-bit Capable, Multi-Core, Hardware Thread, Execute Protection,
+- Enhanced Virtualization, Power/Performance Control etc.
+
+ enumerations:
+ - name: Capability
+@@ -107,64 +95,7 @@ enumerations:
+ - name: PowerPerformanceControl
+ description: >
+ Support power/performance control.
+-
+- - name: Instruction
+- description: >
+- List of capabilities that a processor can support.
+- Values are based off DMTF DSP0134 specification.
+- values:
+- - name: ARM_A32
+- description: >
+- Capable of 64-bit.
+- - name: ARM_A64
+- description: >
+- Support multi-core.
+- - name: IA_64
+- description: >
+- Support hardware thread.
+- - name: MIPS32
+- description: >
+- Support execute protection.
+- - name: MIPS64
+- description: >
+- Support enhanced virtualization.
+- - name: OEM
+- description: >
+- Support power/performance control.
+- - name: PowerISA
+- description: >
+- Support power/performance control.
+- - name: x86
+- description: >
+- Support power/performance control.
+- - name: x86_64
+- description: >
+- Support power/performance control.
+-
+- - name: ProcessorArchitecture
+- description: >
+- Contain the string that identifies the architecture
+- of the processor contained in this socket
+- values:
+- - name: ARM
+- description: >
+- ARM.
+- - name: IA_64
+- description: >
+- Intel Itanium.
+- - name: MIPS
+- description: >
+- MIPS.
+- - name: OEM
+- description: >
+- OEM-defined.
+- - name: Power
+- description: >
+- Power.
+- - name: x86
+- description: >
+- x86 or x86-64.
+-
++
+ associations:
+ - name: associated_pcie_slots
+ description: >
+--
+2.35.1
+
diff --git a/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend b/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
index fa37528261..d5ebf82c60 100644
--- a/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
+++ b/meta-ibs/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
@@ -24,4 +24,5 @@ SRC_URI += "file://0007-ipmi-set-BIOS-id.patch \
file://0003-Add-new-fields-to-cpu.patch \
file://0037-add-new-dimm-fields.patch \
file://0038-repair_telemetry_yaml.patch \
+ file://0039-Change-CPU-interface-according-to-latest-upstream-ve.patch \
"