summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common/recipes-core
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2022-01-22 01:07:24 +0300
committerJason Bills <jason.m.bills@linux.intel.com>2022-01-27 01:07:11 +0300
commit9a2bb3009d0a30c106f60d6ebbd3f494b1d0fc67 (patch)
tree8ae079b3c473b46987dc8fd544c2c21a77a25420 /meta-intel-openbmc/meta-common/recipes-core
parenta63df9202afd9fd7a3f57e9f5aa0dc46cd64b2fd (diff)
downloadopenbmc-9a2bb3009d0a30c106f60d6ebbd3f494b1d0fc67.tar.xz
libpeci: Add option to build the raw PECI daemon
This adds a PACKAGECONFIG option to build the new D-Bus raw PECI daemon. Tested: Enabled this option and confirmed that the raw-peci daemon is started and can handle raw PECI commands sent over D-Bus. Change-Id: Ic37aced8f2b0b3502021206b5582cd1c47bd253f Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-intel-openbmc/meta-common/recipes-core')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb b/meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb
index b41d8b12f3..9e4715f95d 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "PECI Library"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
-inherit cmake
+inherit cmake pkgconfig systemd
SRC_URI = "git://github.com/openbmc/libpeci;branch=master;protocol=https"
@@ -11,3 +11,7 @@ PV = "0.1+git${SRCPV}"
SRCREV = "bdefaa3c95d0a93928f8ebda1ce158172d3a4bcf"
S = "${WORKDIR}/git"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[dbus-raw-peci] = "-DDBUS_RAW_PECI=ON,-DDBUS_RAW_PECI=OFF,boost sdbusplus"
+SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'dbus-raw-peci', 'com.intel.peci.service', '', d)}"